Find the answer to your Linux question:
Results 1 to 2 of 2
I run RH8. I got the new Gnome 2.2 rpms for RH8 from a LinuxFormat magazine. I tried to install the rpms with little success due to dependencies. So I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User
    Join Date
    Jan 2003
    Location
    Cardiff, Wales
    Posts
    478

    oops I broke X


    I run RH8. I got the new Gnome 2.2 rpms for RH8 from a LinuxFormat magazine.

    I tried to install the rpms with little success due to dependencies. So I decided to force the issue.

    Ran rpm -Uvh --nodeps --force *.rpm

    Installed OK. Rebooted X server. Nothing happened just mouse pointer (X).

    So restarted PC.
    Message states X respawning too fast disabled for 5 mins.

    Logged in manually and started X
    got following error

    file libXrandr.so.2 cannot be found.

    Ooops! Any ideas howto fix it!

    Otherwise will wait for RH9 or maybe try the new mandrake as a friend is running that and it looks pretty good. Also has urpmi gui for software updating.
    No trees were harmed during the creation of this message. Its made from a blend of elephant tusk and dolphin meat.

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Oooh... dependencies often have reasons. Best option I can think of is reinstalling the original Gnome RPMs from the RedHat CDs. Try creating a file list of the RPMs to be installed, like this, having the LinuxFormat CD inserted:
    Code:
    ls /mnt/cdrom/path/to/files/*.rpm | sed 's/[0-9.-]*\.i386\.rpm$//' >~/rpmlist
    Then "mkdir /tmp/rpms", insert the RedHat installation CDs, one in turn, and run this for each one (mount and unmount yourself as you see fit):
    Code:
    for file in `cat ~/rpmlist`; do path=`ls /mnt/cdrom/RedHat/RPMS/* | grep "$file"'[0-9.-]*\.i386\.rpm'`; if [ -e $path ]; then echo $file; cp $path /tmp/rpms; fi; done
    That should also give you a list of RPMs copied from each CD.
    When all is done, go to /tmp/rpms and do this:
    Code:
    rpm -Uhv --nodeps --force *.rpm
    Note! I don't know if this will work or anything, it's just the best I can think of.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •