Find the answer to your Linux question:
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 25
Every time my computer boots up X fails to start. To get it working I need to reinstall the NVIDIA drivers. The Xorg log file has the following error: (EE) ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Engineer Kieren's Avatar
    Join Date
    Aug 2007
    Location
    England
    Posts
    848

    NVIDIA need reinstalling after every reboot


    Every time my computer boots up X fails to start. To get it working I need to reinstall the NVIDIA drivers.

    The Xorg log file has the following error:

    (EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module! Please ensure
    (EE) NVIDIA(0): that there is a supported NVIDIA GPU in this system, and
    (EE) NVIDIA(0): that the NVIDIA device files have been created properly.
    (EE) NVIDIA(0): Please consult the NVIDIA README for details.
    (EE) NVIDIA(0): *** Aborting ***
    (EE) Screen(s) found, but none have a usable configuration.

    Any ideas on how to fix this?
    Linux User #453176

  2. #2
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Just guessing here, but try using your package manager to actually remove your old nvidia package, then use it again to reinstall the nvidia package.
    oz

  3. #3
    Linux Engineer Kieren's Avatar
    Join Date
    Aug 2007
    Location
    England
    Posts
    848
    The driver was installed manually so it can't be removed with the package manager
    Linux User #453176

  4. #4
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Ok, you might try removing it manually, and then reinstalling manually. If you've installed one version over another, I'm thinking the new version is not completely overwriting the old one, hence you to have to reinstall on each boot.

    That's what happened to me on the my last nvidia driver upgrade.
    oz

  5. #5
    Linux Engineer Kieren's Avatar
    Join Date
    Aug 2007
    Location
    England
    Posts
    848
    How would I go about removing it manually?
    Linux User #453176

  6. #6
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    From the sounds of it the module isn't auto-loading on boot. This used to happen a good bit in SUSE and Mandriva - are you using either of these distros?

    Post the contents of /etc/modprobe.conf and/or /etc/modules. If you are using SUSE open YaST, /etc/sysconfig-editor and then check out the section under kernel MODULES_LOADED_ON_BOOT checking for an entry for nVidia.

  7. #7
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    If it turns out not to be the module problem as suggested by bigtomrodney, you can go to your nvidia installation directory and try using the --uninstall option to remove it. You might find some directions for using the option in a readme file in that directory.
    oz

  8. #8
    Linux Engineer Kieren's Avatar
    Join Date
    Aug 2007
    Location
    England
    Posts
    848
    # /etc/modules: kernel modules to load at boot time.
    #
    # This file contains the names of kernel modules that should be loaded
    # at boot time, one per line. Lines beginning with "#" are ignored.

    fuse
    lp

    I'm using Kubuntu
    Linux User #453176

  9. #9
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    Add a line to that file like this -
    Code:
    # /etc/modules: kernel modules to load at boot time.
    #
    # This file contains the names of kernel modules that should be loaded
    # at boot time, one per line. Lines beginning with "#" are ignored.
    
    fuse
    lp
    nvidia
    Alternatively if possible, remove the driver using the .run file (you can check how using the options --help) and try to use the Restricted Drivers manager to install the driver. That way any kernel updates will automatically include a new driver rather than needing to recompile the kernel shim.

  10. #10
    Linux Engineer Kieren's Avatar
    Join Date
    Aug 2007
    Location
    England
    Posts
    848
    Tried all these things...

    The only thing that allowed me to start my xserver was to uninstall the driver with the Restricted Drivers manager
    Linux User #453176

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •