Find the answer to your Linux question:
Results 1 to 7 of 7
Ok, I know this has probably been asked a million times, but I really can't find a solution. I'm running Fedora Core 2 with fluxbox. I installed X when I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2004
    Posts
    5

    Screen Resolution Help...


    Ok, I know this has probably been asked a million times, but I really can't find a solution.

    I'm running Fedora Core 2 with fluxbox. I installed X when I installed FC2. I can't find XF86Config anywhere, which seems very odd. The problem is that the highest resolution I can use is 1024x768, but I can get 1600x1200 in windows.

    Thanks for any help,
    jtnw

  2. #2
    Linux Guru
    Join Date
    Apr 2003
    Location
    London, UK
    Posts
    3,284
    typically in - /etc/X11/XF86Config, or if your using version 4 of the X server, it will be /etc/X11/XF86Config-4

    Jason

  3. #3
    Just Joined!
    Join Date
    Aug 2004
    Posts
    5
    That's the odd thing... it's not there. I tried "find / XF86Config" but that's didn't find it.

    jtnw

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Apr 2003
    Location
    London, UK
    Posts
    3,284
    ok, i've done a bit of research and the file you need is "xorg.conf" (in /etc/ i would guess?). from what i understand xorg.conf is the new xf86 config file for fedora 2.

    Jason

  6. #5
    Just Joined!
    Join Date
    Aug 2004
    Posts
    5
    Ok, I found xorg.conf, and I changed it so it has 1600x1200 in it, but it still uses 1024x768... Here's what it looks like:
    Code:
    Section "Monitor"
            Identifier   "Monitor0"
            VendorName   "Monitor Vendor"
            ModelName    "IBM P76"
            DisplaySize  330        240
            HorizSync    30.0 - 94.0
            VertRefresh  48.0 - 120.0
            Option      "dpms"
    EndSection
    
    Section "Device"
            Identifier  "Videocard0"
            Driver      "nv"
            VendorName  "Videocard vendor"
            BoardName   "RIVA128"
    EndSection
    
    Section "Screen"
            Identifier "Screen0"
            Device     "Videocard0"
            Monitor    "Monitor0"
            DefaultDepth     24
            SubSection "Display"
                    Viewport   0 0
                    Depth     24
                    Modes    "1600x1200"
            EndSubSection
    EndSection
    jtnw

  7. #6
    Just Joined!
    Join Date
    Sep 2004
    Posts
    3

    Xorg Video Resolutions

    Hiya
    First thing I noticed is that you are using the "nv" driver. Why not use the native nVidia accellerated driver downloadable from nvidia.com? It is highly developed and uses the Loki installer binary so it's a no-brainer but yet does an excellent job w/o doing a buncha crap behind your back. In fact you must read the "readme" to see how to edit "xorg.conf" but included is an excellent example that is in itself highly instructive to most peeps. Besides being accellerated and essential to any gaming it delivers verbose output to the "/var/log/Xfree86.log.0" which will give you a lot of data to help you determine why a resolution has been discarded even whan it is specified.

    It is difficult if not impossible to give you more help since you list no monitor/screen data which is where X gets an idea of what you want to run and what can be run. It is a good idea to find and read a manual, online or otherwise, for your exact model monitor so you can input precise synch rates that allow X to utilize all possible modes. Incidentally I hope you default to a console login so that you don't have to deal w/ X failures by rebooting to a maintenance mode . All you really need to operate from console to maintain x config is a good editor like VI, VIM, Elvis, or whatever text editor you like. It is also where you must go to install the nVidia driver. Once there and configured all you need is XDM, GDM, or KDM ( your choice ) of login and display managers that allow you to operate multiple choices of desktops and/or window managers. Besides, it's 1337.

    Hope this helps
    Jimmy

  8. #7
    Just Joined!
    Join Date
    Sep 2004
    Posts
    23

    This solved my resolution problem!

    Hi..
    In my XOrgConfig file I found the following:

    Section "Device"

    Identifier "Videocard0"

    Driver "cirrus"

    VendorName "Videocard vendor"

    BoardName "Cirrus Logic GD5446"

    VideoRam 2048

    EndSection

    The VideoRam value was 1024 and I changed it to 2048 since my Vcard is 2Mb Ram(dont be surbrised!)...and It solved the problem,..so u can add such a line indicating ur real video card RAM..also at the SAME STEP delete all modes in the file and leave ONLY the required mode...save the file and restart the X server..
    I hope this will help u..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •