Find the answer to your Linux question:
Results 1 to 5 of 5
Hi all... I am trying to install GTK and followed following steps... 1. Downloaded glib-2.5.1,gtk+-2.5.5, atk-1.7.2, pango-1.4.1. These are the packages that I came to know that are needed as ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2004
    Posts
    9

    Stucked while configuring GTK


    Hi all...

    I am trying to install GTK and followed following steps...
    1. Downloaded glib-2.5.1,gtk+-2.5.5, atk-1.7.2, pango-1.4.1. These are the packages that I came to know that are needed as per the docs I came accross.
    2. Installed glib-2.5.1...this is successfully done from my knowledge.
    a. tar xvfz glib-2.5.1.tar.gz
    b. ./configure --prefix=/opt/gtk
    c. make.
    d. make install.
    e. ldconfig.
    3. When I install gtk it says atk not found in the pkg-config search path. So I tried to install atk-1.7.2. In the process of installation while using the make command I get the following error.

    [root@jds atk-1.7.2]# make
    make all-recursive
    make[1]: Entering directory `/usr/local/atk-1.7.2'
    Making all in atk
    make[2]: Entering directory `/usr/local/atk-1.7.2/atk'
    ..//usr/local/glib-2.5.1/gobject/glib-genmarshal --prefix=atk_marshal ./atkmarshal.list --header >> xgen-gmh \
    al.list --header >> xgen-gmh \
    && (cmp -s xgen-gmh atkmarshal.h || cp xgen-gmh atkmarshal.h) \
    && rm -f xgen-gmh xgen-gmh~ \
    && echo timestamp > stamp-atkmarshal.h
    /bin/sh: line 1: ..//usr/local/glib-2.5.1/gobject/glib-genmarshal: No such file
    or directory
    make[2]: *** [stamp-atkmarshal.h] Error 127
    make[2]: Leaving directory `/usr/local/atk-1.7.2/atk'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/usr/local/atk-1.7.2'
    make: *** [all] Error 2

    Can anyone tell me y is this happening? Hpw can I get through this error and proceed ahead...

    Thanx
    Vishal G.

  2. #2
    Just Joined!
    Join Date
    Jul 2004
    Location
    UK
    Posts
    77
    It looks like glib hasn't installed correctly.

    Armage

  3. #3
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    I think you need to install glib-devel package.

    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  4. #4
    Just Joined!
    Join Date
    Jun 2005
    Posts
    2

    Re: Stucked while configuring GTK

    hi goelvish!
    I have the same problem as you had it last year!
    now my question: have you solved it?
    i would really appreciate your answer!!!
    thanks,
    tanne

  5. #5
    Just Joined!
    Join Date
    Jun 2005
    Posts
    2

    Re: Stucked while configuring GTK

    hi! i had the same problem and i found a solution, at least a solution that works for me! as i'm not really good in this topic please don't be too strict when reading my post. there might be a lot of not useful things or even wrong ones, but maybe my post helps some other people who have the same problem!

    take a look at the really great explanation:
    http://www.linuxforums.org/forum/topic-45270.html

    do it as proposed there for glib and atk:
    (for me mypath is the same for glib and atk!
    but i don't know if that is a must!)

    important: before ./configure --prefix=/mypath
    set the env. variables:

    export PKG_CONFIG_PATH=/mypath/lib/pkgconfig
    export PKG_CONFIG_LIBDIR=/mypath/lib/
    export LD_LIBRARY_PATH=/mypath/lib/
    export LDFLAGS="-L/mypath/lib"
    export CPPFLAGS="-I/mypath/lib"

    then: configure, make, make install

    (after that, if there is still a problem with glib-genmarshal:
    export PATH=$PATH:/mypath/bin)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •