Find the answer to your Linux question:
Page 3 of 3 FirstFirst 1 2 3
Results 21 to 29 of 29
Oh, when trying to get this stuff working, do NOT use KDE or GNOME. Either of them will try to override the default resolution setting if you've ever set the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #21
    Linux User IsaacKuo's Avatar
    Join Date
    Feb 2005
    Location
    Baton Rouge, LA, USA
    Posts
    405

    Oh, when trying to get this stuff working, do NOT use KDE or GNOME. Either of them will try to override the default resolution setting if you've ever set the resolution using their respective control center utilities. A lightweight window manager like IceWM won't ever try to override the default resolution setting so that eliminates one possible source of confusion.

    Regardless, I do not think your font issue results from using the wrong resolution. If you're using KDE, you can try changing the font settings in KDE's control center. In particular, since you're using an LCD screen you'll want to set the anti-aliasing mode to sub-pixel rendering. This will make fonts less blurry than the default anti-aliasing mode (which is good for CRT monitors, DLP, and triple LCD projectors).

    Another thing is that many fonts don't have good hinting. I'd try setting all of KDE's fonts to Deja Sans, which is pretty crisp. Many other fonts are just plain blurry.

    In Debian 4.0 (Etch), the Sans Serif font is aliased to Deja Sans (in Debian 3.1, the default Sans Serif font was Bitstream Vera Sans...I don't know why the difference). I like the clean appearance of Deja Sans enough that I usually set Firefox to use ONLY Deja Sans. In Firefox's somewhat counterintuitive font settings, it's possible to change all fonts to Deja Sans except for Monospace, which I set to Deja Sans Mono. Then there's a checkbox to let web pages choose their own fonts--I uncheck this box.

    This is particularly useful for my computers with very limited RAM. Only one or two font sets get loaded into memory.
    Isaac Kuo, ICQ 29055726 or Yahoo mechdan

  2. #22
    Just Joined!
    Join Date
    Sep 2005
    Posts
    17
    I installed IceWM.
    Nice lean manager.
    Unfortunately this doesn't help.
    The resolution, dpi and screen size are said to be OK with xdpyinfo.
    But the screen is still very blurred.
    It is not a font issue as such, because I tried all sorts of fonts. Also Tahoma with several settings. The Deja Sans which I use now is very difficult to read.

    I still have the idea it is the refresh rate which is too low. With a lower resolution with the the vesa driver, but at 60Hz it is much better.
    Upto now I have not been able in any way to get the 1680x1050 / 60Hz combination.

    I hope you haven't run out of ideas yet?

    Thanks for your efforts!

  3. #23
    Linux User IsaacKuo's Avatar
    Join Date
    Feb 2005
    Location
    Baton Rouge, LA, USA
    Posts
    405
    This isn't some really old nVidia card, is it? No...I don't think so, based on your earlier comments.

    This is a real long-shot, but maybe worth trying anyway. Maybe your nVidia card can't handle 1680x1050@60hz with 24 bit color. Try changing the default depth to 16.

    (I don't seriously think this will have any effect. You'd have to be using a really old card for it to not handle 1680x1050@60hz with ease.)

    I'll keep thinking about it...
    Isaac Kuo, ICQ 29055726 or Yahoo mechdan

  4. #24
    Just Joined!
    Join Date
    Sep 2005
    Posts
    17
    Dear Isaac,

    thanks a lot for all your work.
    The card is very new, reputed brand (MSI) and fast (7600-series chipset with 512MB RAM). It was the fastest I could get with passive cooling.

    I will still try it with default depth at 16, but I don't think it will have any effect 'cos the card is so new and nice (except for the driver that comes with it of course).

    Thanks again and if you come up with something please let me know.

    Is there any way nVidia can learn about this? I could not find any way to get through to them. The only answers you will get are " have you switched your machine on" and "install the latest driver". After four times communicating you get another person who starts at question 1 again.
    I think it is a bug in the driver, or in X.

    Any suggestions on how to get through to nVidia or the developers of X?

    Anyone else any suggestions on how to solve the problem? Isaac knows so much about it I can't imagine, but who knows...

  5. #25
    Linux User IsaacKuo's Avatar
    Join Date
    Feb 2005
    Location
    Baton Rouge, LA, USA
    Posts
    405
    Actually I'm not an expert on using nVidia's official driver. I speak only from experience a few weeks ago figuring out how to get custom modelines to work with on board nVidia. The open source driver didn't even come close. The official driver was something I eventually got working, but it wasn't easy or obvious!

    I did NOT use the latest driver. I used the nVidia driver in the Debian 4.0 repositories. Here's a description of how I installed it: Debian User Forums :: View topic - What is the Debian way to install nvidia support? [Solved} (scroll down a bit to see my extra bits)
    Isaac Kuo, ICQ 29055726 or Yahoo mechdan

  6. #26
    Just Joined!
    Join Date
    Sep 2005
    Posts
    17
    Dear Isaac,

    thanks a lot for your work.
    It seems that there may, or may not, be a solution using all sorts of replacement drivers for nVidia.
    Now starting to try some of that I get into very serious work, with no guarantee whatsowever of success in installing it, and after that on getting a working system.

    My computer just crashed (hardware) and I can't keep on spending this amount of time on it.

    I find it a real pity that nVidia is too incompetent (did I say that: "incompetent"?. Well, I mean it too.) to simply make a driver that will work with X. I don't say I can do better, but I am also not one of the biggest manufacturers of graphics chips.
    Sorry nVidia, I won't try your chips again!
    Next time it will be ATi or something.

  7. #27
    Linux User IsaacKuo's Avatar
    Join Date
    Feb 2005
    Location
    Baton Rouge, LA, USA
    Posts
    405
    For what it's worth, I found myself annoyed at dealing nvidia drivers years ago, and have bought Ati to my satisfaction since then. I still don't like Ati's official drivers, but I'm happy with the open source ati driver.
    Isaac Kuo, ICQ 29055726 or Yahoo mechdan

  8. #28
    Just Joined!
    Join Date
    Sep 2005
    Posts
    17
    Dear Isaac,

    seems there is a solution after all: dump the (new) nVidia card and buy an ATI card. If you calculate the hours that you spend getting the nVidia card to work (or not, what is more likely) buying a new card is way cheaper. And you learned a useful lesson: don't buy nVidia.

    Thanks again, and this thread can be closed I think (how do I do that?).

  9. #29
    Just Joined!
    Join Date
    Sep 2005
    Posts
    17
    Dear all,

    I bought a new ATi graphics card.
    Now with this one I got both with XP and with Debian an identical response. The quality was good, but my resolution of 1680x1050 was not in the options list. Higher and lower was there, but not that one.
    After trying and communication with the supplier the problem came out: I had used an DVI to D-sub adapter and used the analog input. With the nVidia chip and XP this worked fine.
    With ATi it doesn't, but at least it is consistent.
    After connecting the screen to the DVI input both XP and Debian worked fine and I am happy with my clear and sharp screen.

    LESSON LEARNED: with this screen always use the DVI input. Apparantly with the analog adapter the screen is not properly recognized!
    (Don't ask why and don't ask why there is no warning anywhere in the manual.)

    I wonder if I had connected the nVidia card to the DVI input whether it would have been OK?
    Don't feel like trying it out...

    I would still recommend the ATi card: installing the driver was WAY easier and the XP and Debian driver give the same result, which is so much easier with fault-finding.

    Thanks to you all for your patience and help!

Page 3 of 3 FirstFirst 1 2 3

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •