That's weird. I'm using debian lenny, and as its own packaged fluxbox was having some problems, I tried to compile from source, as described in fluxbox' wiki.

Basically it worked, but then it was ignoring the font and pixmaps specifications in the styles.

Later on, I uninstalled this compiled version (as the original problem hasn't disappeared, apparently), but the new problem remained.

I then went to openbox, moved ~/.fluxbox to .fluxbox.bak, and then "purged" fluxbox and reinstalled. With the original config files that come with the installation, there was no problem. Then I moved to openbox again and restored my customized config files, and it worked! All the new styles, overlay, menu and keys were working perfectly. But the pixmaps were being ignored again, after reboot! (or after exiting X and restarting)

What I did then was to start flux with the original config files to see what happen, and then restore the custom ones... it worked... BUT if I start fluxbox with the custom files, it does not! BUTē if I just alternate to openbox and then to flux again, without doing anything with fluxe's config files, it will read the pixmaps and all my custom files!

(by the way, it's affecting only the pixmaps, the "keys" work even when the styles are weird, pixmapless)

That's weird... I think it must be some sort of permission issue... but I've run konqueror as root, and clicked on .fluxbox folder properties > permissions and set that my user and group has permissons to read and write, with that option to apply to subfolders and files marked. Unless this konqueror's is buggy, that wouldn't be quite the case. Furthermore, the permissions show as identical on konqueror's detailed view...

The .xinitrc is exactly the same that was working perfectly before...

Anyone has some idea of what might be going on?




__________________________________________________ __

EDITED:

Solved, but not quite figured how

Turns out that it can be "solved" by calling fluxbox on .xinitrc by:

exec /bin/fluxbox

instead of

exec fluxbox

!!!!

I guessed that something like that could be happeninig as I noticed that when alternating the WM from within a WM, the one I move to would not restart xinitrc, but rather some thing of its own, "./fluxbox/startup" in the case of fluxbox specifically. So I noticed this little difference between the scripts and decided that it couldn't get any worse if I tried.

I just can't understand WHY it works, if it was working just fine before with "exec fluxbox"!



I'll keep the topic open, just in case someone passes by and thinks "I can answer that..."


Now there's only one problem to solve at least...