Find the answer to your Linux question:
Results 1 to 4 of 4
Hi all. I was trying to install wireshark and ran into this error. Code: *** Could not run GTK+ test program, checking why... *** The test program failed to compile ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2007
    Posts
    52

    No GTK+ ?


    Hi all. I was trying to install wireshark and ran into this error.

    Code:
    *** Could not run GTK+ test program, checking why...
    *** The test program failed to compile or link. See the file config.log for the
    *** exact error that occured. This usually means GTK+ is incorrectly installed.
    configure: error: GTK+ isn't available, so Wireshark can't be compiled
    Now i did a bit of research on what GTK+ was and so on and found out that it should already be on my machine. But just in case that its not, how would i find out? And how would i install it with the yum package manager? Thanx in advance!

  2. #2
    Linux Guru bryansmith's Avatar
    Join Date
    Nov 2004
    Location
    /Ontario/Canada
    Posts
    2,619
    Are you using KDE or GNOME? If you are using GNOME, then GTK is already installed and then you have a problem (GTK is the toolkit used for GNOME). If you have KDE installed, simply installing GTK should do the trick.

    Have you tried installing wireshark with yum yet?

    Bryan
    Looking for a distro? Look here.
    "There can be no doubt that all our knowledge begins with experience." - Immanuel Kant (Critique of Pure Reason)
    Queen's University - Arts and Science 2008 (Sociology)
    Registered Linux User #386147.

  3. #3
    Linux Guru
    Join Date
    Nov 2007
    Location
    Córdoba (Spain)
    Posts
    1,513
    Note also that gtk-1.x is not compatible with gtk-2.x. So, if this program requires gtk-1.x you will need to install gtk-1.x, even if you aready have gtk-2, that is, unless you are willing to port the program so it can work using gtk2 instead.

  4. #4
    Just Joined!
    Join Date
    Dec 2007
    Posts
    52
    Quote Originally Posted by bryansmith View Post
    Have you tried installing wireshark with yum yet?
    Yeah that was my first choice, But i couldnt find it. It wasnt in the Applications menu nor anywhere. I couldnt launch it from console or anything. I could find the files needed to run it but i couldnt launch it at all. So i tried to compile it from source and i got that error =/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •