Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
Hi I have a old IBM Thinkpad 1711 I have Debain Linux Lenny Testing installed on it And the screen resolution is set to 800*600 but the screen is 1024*768 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2007
    Posts
    8

    [SOLVED] Resolution Problem


    Hi
    I have a old IBM Thinkpad 1711
    I have Debain Linux Lenny Testing installed on it
    And the screen resolution is set to 800*600 but the screen is 1024*768
    But there no option for 1024*768 in the options fir screen resolution
    I'm using Gnome
    Heres my xorg.conf file

    Code:
    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "InputDevice"
    	Identifier	"Generic Keyboard"
    	Driver		"kbd"
    	Option		"XkbRules"	"xorg"
    	Option		"XkbModel"	"pc104"
    	Option		"XkbLayout"	"us"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Configured Mouse"
    	Driver		"mouse"
    EndSection
    
    Section "Device"
    	Identifier	"Configured Video Device"
    EndSection
    
    Section "Monitor"
    	Identifier	"Configured Monitor"
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Monitor		"Configured Monitor"
    EndSection
    I'll answer any questions you have to ask me to help you help me as soon as I can
    Thanks

  2. #2
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    Try adding resoultion entries for your screen. Do you know what driver you are using? It's better to specify a driver, in this case I'll assume vesa. Backup your xorg.conf and try adding these lines to the Screen section above then restart X by hitting CTRL+ALT+BACKSPACE.
    Code:
    Section "Screen"
    	Identifier	"Default Screen"
    	Monitor		"Configured Monitor"
    	DefaultDepth	24
    	SubSection "Display"
    		Depth		1
    		Modes		"1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		4
    		Modes		"1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		8
    		Modes		"1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		15
    		Modes		"1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		16
    		Modes		"1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		24
    		Modes		"1024x768" "800x600" "640x480"
    	EndSubSection
    EndSection

  3. #3
    Just Joined!
    Join Date
    Jul 2007
    Posts
    8
    Nope Didn't do anything
    X still working at least
    But it's still at 800*600 and theres no options for anything higher
    I don't think it's reading what the screen resolution should be from the xorg file
    And I don't know what gpu I have if any
    Or what driver I'm running for ghx
    Any way to check this?

  4. $spacer_open
    $spacer_close
  5. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Execute this
    Code:
    su -
    lspci | grep -i vga
    Post output here.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  6. #5
    Just Joined!
    Join Date
    Jul 2007
    Posts
    8
    http://dreamlinuxforums.org/index.ph...c,2411.15.html
    Check this out
    xorg has been updated and thats the problem but the new xorg sultion isn't working for me still
    See the link it will explain

    and
    Code:
    # lspci | grep -i vga
    01:00.0 VGA compatible controller: Trident Microsystems CyberBlade/i1 (rev 5d)

  7. #6
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Try trident driver.
    Edit Video Card section in xorg.conf file and reboot machine,
    Code:
    Section "Device"
    	Identifier	"Configured Video Device"
            Driver       "trident"
    EndSection
    In case it doesn't work, press Alt+Ctrl+F1 and remove it.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  8. #7
    Just Joined!
    Join Date
    Jul 2007
    Posts
    8
    I'm using the trident driver now
    It's doing no help

  9. #8
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    I will check if Trident Card is supported by Linux or not. Meanwhile, try replacing "vesa" with "trident" in xorg.conf file.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  10. #9
    Just Joined!
    Join Date
    Jul 2007
    Posts
    8
    I did
    Thats how I'm using the trident driver
    But everything is still at 800*600

  11. #10
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Quote Originally Posted by spaje View Post
    I did
    Thats how I'm using the trident driver
    But everything is still at 800*600
    Have you tried to replace trident with vesa in xorg.conf file?
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •