Find the answer to your Linux question:
Results 1 to 10 of 10
I have an installation of CentOS 3.9 sharing a HDD with Ubuntu 8.04. I recently upgraded from a CRT to an LCD. Ubuntu works fine with the new monitor, but ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    May 2007
    Posts
    106

    Lost display after monitor switch


    I have an installation of CentOS 3.9 sharing a HDD with Ubuntu 8.04. I recently upgraded from a CRT to an LCD. Ubuntu works fine with the new monitor, but CentOS does not. The system boots as normal, but when X loads the monitor blacks out and says "Cannot Display This Video Mode".

    I can access the box via SSH. What should I do to get X back?

    all ideas appreciated

  2. #2
    Linux Guru
    Join Date
    Nov 2007
    Location
    Córdoba (Spain)
    Posts
    1,513
    Quote Originally Posted by charlie205 View Post
    I have an installation of CentOS 3.9 sharing a HDD with Ubuntu 8.04. I recently upgraded from a CRT to an LCD. Ubuntu works fine with the new monitor, but CentOS does not. The system boots as normal, but when X loads the monitor blacks out and says "Cannot Display This Video Mode".

    I can access the box via SSH. What should I do to get X back?

    all ideas appreciated
    Check the monitor manual, get the correct mode lines and refresh values for it, and change /etc/X11/xorg.conf accordingly.

    Note that incorrect refresh values might prevent the X server to start. You also need to set a correct resolution for it. If in doubt, paste your xorg.conf in pastebin.com and let us know your monitor specifications, or at least the model.

  3. #3
    Linux Newbie
    Join Date
    May 2007
    Posts
    106
    I will give this a try, but I am away from my machine for the weekend. I will be able to try this on Monday. Thanks for the tip.

    Also, I swapped out monitors (due to an unrelated event) and am having a similar problem with the new monitor. I'll follow the same advice and let you know what happens.

    thanks again

  4. #4
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,628
    Another thing to try: Since Ubuntu gives no problems, make a comparison between your xorg.conf's from Ubuntu and CentOS. Find out what the differences are and determine what needs to be changed in the CentOS xorg.conf.
    Linux Mint + IceWM Registered:#371367 New Members: click here

  5. #5
    Linux Guru
    Join Date
    Nov 2007
    Location
    Córdoba (Spain)
    Posts
    1,513
    Quote Originally Posted by Dapper Dan View Post
    Another thing to try: Since Ubuntu gives no problems, make a comparison between your xorg.conf's from Ubuntu and CentOS. Find out what the differences are and determine what needs to be changed in the CentOS xorg.conf.
    You should also be able to just copy it, as long as you are using the same drivers 'n stuff in both and the versions of xorg are relatively close (even if not, no big problem should arise either).

  6. #6
    Linux Newbie
    Join Date
    May 2007
    Posts
    106
    I copied /etc/X11/xorg.conf from my ubuntu install to my CentOS install. X loads and works fine, except the monitor displays "Input Signal out of Range". This only happens while X is running under CentOS. One note - this problem began with a different monitor which would not load X at all. I swapped monitors (from a dell to a i-inc) and X would display, but it always gave the above error. So, copying the xorg.conf file netted no actual result (i.e. the display worked w/error before and after the file was copied).

    Here is the model of my monitor:
    I-Inc CY199D 19 Inch Active Matrix TFT Display

    Product Specifications:
    General
    Display Type TFT LCD
    Viewable Screen Size 19 inches
    Brightness 250 cd/m2
    Contrast Ratio 700 : 1
    Pixel Pitch 0.294mm x 0.294mm
    Response Time 8 ms
    Viewing Angle (H/V) 150 / 135 degrees
    Maximum Resolution 1280 x 1024 SXGA
    Color Black
    MTBF 50,000 hours
    Power Supply 100VAC - 240VAC 50/60Hz Autodetect
    Power Consumption 42W Maximum


    I've also appended the text of my xorg.conf file. Notice the screen section lists "default" and the monitor section lists the old CRT I used when I built this system originally.

    # xorg.conf (xorg X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    # sudo dpkg-reconfigure -phigh xserver-xorg

    Section "Files"
    EndSection

    Section "InputDevice"
    Identifier "Generic Keyboard"
    Driver "kbd"
    Option "CoreKeyboard"
    Option "XkbRules" "xorg"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us"
    EndSection

    Section "InputDevice"
    Identifier "Configured Mouse"
    Driver "mouse"
    Option "CorePointer"
    Option "Device" "/dev/input/mice"
    Option "Protocol" "ImPS/2"
    Option "ZAxisMapping" "4 5"
    Option "Emulate3Buttons" "true"
    EndSection

    Section "InputDevice"
    Driver "wacom"
    Identifier "stylus"
    Option "Device" "/dev/input/wacom"
    Option "Type" "stylus"
    Option "ForceDevice" "ISDV4" # Tablet PC ONLY
    EndSection

    Section "InputDevice"
    Driver "wacom"
    Identifier "eraser"
    Option "Device" "/dev/input/wacom"
    Option "Type" "eraser"
    Option "ForceDevice" "ISDV4" # Tablet PC ONLY
    EndSection

    Section "InputDevice"
    Driver "wacom"
    Identifier "cursor"
    Option "Device" "/dev/input/wacom"
    Option "Type" "cursor"
    Option "ForceDevice" "ISDV4" # Tablet PC ONLY
    EndSection

    Section "Device"
    Identifier "ATI Technologies Inc Rage 128 PF/PRO AGP 4x TMDS"
    Driver "ati"
    BusID "PCI:2:0:0"
    EndSection

    Section "Monitor"
    Identifier "Q95-2"
    Option "DPMS"
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Device "ATI Technologies Inc Rage 128 PF/PRO AGP 4x TMDS"
    Monitor "Q95-2"
    DefaultDepth 24
    SubSection "Display"
    Modes "1600x1200" "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    EndSection

    Section "ServerLayout"
    Identifier "Default Layout"
    Screen "Default Screen"
    InputDevice "Generic Keyboard"
    InputDevice "Configured Mouse"

    # Uncomment if you have a wacom tablet
    # InputDevice "stylus" "SendCoreEvents"
    # InputDevice "cursor" "SendCoreEvents"
    # InputDevice "eraser" "SendCoreEvents"
    EndSection

  7. #7
    Linux Guru
    Join Date
    Nov 2007
    Location
    Córdoba (Spain)
    Posts
    1,513
    Hi,

    I would add the refresh rates to your monitor specifications:

    Code:
    Section "Monitor"
    	Identifier	"Q95-2"
    	Option		"DPMS"
            HorizSync 24-80
            VertRefresh 56-75
    EndSection
    Those values are correct attending at the specs in the pdf manual for your monitor, page 7.

  8. #8
    Linux Newbie
    Join Date
    May 2007
    Posts
    106
    Quote Originally Posted by i92guboj View Post
    Code:
    Section "Monitor"
    	Identifier	"Q95-2"
    	Option		"DPMS"
            HorizSync 24-80
            VertRefresh 56-75
    EndSection
    I added the necessary lines to my xorg.conf file to make it match the above, but the problem was not resolved. I'm not sure if i mentioned it before, but when i copied xorg.conf from Ubuntu to CentOS I noticed in the CentOS directory /etc/X11 there was no xorg.conf file.

    Is it possible another file is controlling X? This is CentOS 3.9 so it's pretty old.

  9. #9
    Linux Guru
    Join Date
    Nov 2007
    Location
    Córdoba (Spain)
    Posts
    1,513
    Quote Originally Posted by charlie205 View Post
    I added the necessary lines to my xorg.conf file to make it match the above, but the problem was not resolved. I'm not sure if i mentioned it before, but when i copied xorg.conf from Ubuntu to CentOS I noticed in the CentOS directory /etc/X11 there was no xorg.conf file.

    Is it possible another file is controlling X? This is CentOS 3.9 so it's pretty old.
    xorg.conf(5x) manual page

    That's the xorg 6.8. As you can see at the very top of the man page, there are many locations where that file could reside.

    Besides that, I have no experience with CentOS, so, maybe it's still using XFree instead of xorg, in that case the config files will be different.

  10. #10
    Linux Newbie
    Join Date
    May 2007
    Posts
    106
    fair enough. thanks for the tips. I'll look around for the appropriate conf file and see if i can make a similar change.

    thanks again

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •