Find the answer to your Linux question:
Results 1 to 8 of 8
I am trying to get dual monitors working in Redhat. I can get twin view working because I can drag windows off the screen and my workspace switcher shows an ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2008
    Posts
    11

    Dual Monitors - One is always in PowerSave Mode


    I am trying to get dual monitors working in Redhat. I can get twin view working because I can drag windows off the screen and my workspace switcher shows an extra wide desktop. However, the second monitor always remains in Powersave mode.

    I have a Quadro FX 1700 video card. One Dell 2009W (1680x1050) monitor (the primary one) and one Dell 1908FP (1280x1024). I also have compiz working. Any suggestions?

    Thanks

  2. #2
    Just Joined!
    Join Date
    Jul 2008
    Posts
    11
    I'm not exactly sure what the deal is, but I found another monitor that would show it with a blueish tint, and yet another that would show it orange.

  3. #3
    Just Joined!
    Join Date
    Jul 2008
    Posts
    11
    Desktop Effects is my problem. If I do not have it enabled, dual head works fine. Anyone know how to get Desktop effects to work in dual head mode as well?

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User twoHats's Avatar
    Join Date
    Jan 2005
    Location
    NH, USA
    Posts
    280

    Dual Head

    I am trying to get dual monitors working in Redhat. I can get twin view working because I can drag windows off the screen and my workspace switcher shows an extra wide desktop. However, the second monitor always remains in Powersave mode.
    Just read that both monitors must use same color depth- HTH
    - Clouds don't crash - Bertrand Meyer

    registered Linux user 393557

    finally - hw to brag about - but next year it will look pitifully quaint:
    Athlon64 X2 3800 - 1G PC3200 - 250G SATA - ati radeon x300
    circa 2006

  6. #5
    Just Joined!
    Join Date
    Jul 2008
    Posts
    11
    I discovered dual head would wor fine if I disabled desktop effects. However, I was turning things on and off, randomly, (thats usually what I do out of desperation, lol), and I got it to work. So now I have dual head and desktop effects running. I'll post the xorg.conf file if anyone is interested. (I know I'm not the only person to get this working, but yet another place where someone might find it useful isn't a bad thing.)

  7. #6
    Linux User twoHats's Avatar
    Join Date
    Jan 2005
    Location
    NH, USA
    Posts
    280

    xorg.conf appreciated

    Hey Thanks for the offer - I for one would love to see xorg.conf.

    -- A fellow random trial and error person - sometimes the magic works - sometimes it doesn't.
    - Clouds don't crash - Bertrand Meyer

    registered Linux user 393557

    finally - hw to brag about - but next year it will look pitifully quaint:
    Athlon64 X2 3800 - 1G PC3200 - 250G SATA - ati radeon x300
    circa 2006

  8. #7
    Just Joined!
    Join Date
    Jul 2008
    Posts
    11
    This works for the Quadro FX 1700 video card, using driver version: NVIDIA-Linux-x86_64-173.14.12-pkg2 on Red Hat Enterprise Linux 64 bit. Probably work on other things as well.

    Code:
    Section "ServerLayout"
        Identifier     "single head configuration"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
    EndSection
    
    Section "Module"
        Load           "glx"
        SubSection     "extmod"
            Option         "omit xfree86-dga"
        EndSubSection
    EndSection
    
    Section "ServerFlags"
        Option         "Xinerama" "0"
    EndSection
    
    Section "InputDevice"
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/input/mice"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
        Identifier     "Keyboard0"
        Driver         "kbd"
        Option         "XkbModel" "pc105"
        Option         "XkbLayout" "us"
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "DELL 2009W"
        HorizSync       30.0 - 83.0
        VertRefresh     56.0 - 75.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Videocard0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "Quadro FX 1700"
        Option         "AddARGBGLXVisuals" "True"
        Option         "RenderAccel" "True"
        Option         "AllowGLXWithComposite" "True"
        Option         "backingstore" "True"
        Option         "TripleBuffer" "True"
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Videocard0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "TwinView" "1"
        Option         "metamodes" "DFP-0: nvidia-auto-select +0+0, DFP-1: nvidia-auto-select +1680+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection

  9. #8
    Linux User twoHats's Avatar
    Join Date
    Jan 2005
    Location
    NH, USA
    Posts
    280

    Thanks!

    Thanks for the post!
    - Clouds don't crash - Bertrand Meyer

    registered Linux user 393557

    finally - hw to brag about - but next year it will look pitifully quaint:
    Athlon64 X2 3800 - 1G PC3200 - 250G SATA - ati radeon x300
    circa 2006

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •