Find the answer to your Linux question:
Results 1 to 6 of 6
Hi, I just built a new system and installed Gentoo. I'm using the system as a personal file/backup server and I would also like to set it up as a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2006
    Posts
    6

    Intel G45 driver


    Hi, I just built a new system and installed Gentoo. I'm using the system as a personal file/backup server and I would also like to set it up as a htpc (since all my music and movies will be stored there anyway). I bought the Gigabyte S-series EG45M-DS2H MoBo with Intel's G45 graphics chipset because I like the onboard HDMI interface.

    Before I purchased, I read that Intel's newest drivers were updated to include support for this chipset, so I downloaded and installed xf86-video-intel 2.4.2 from Intel Linux Graphics: Downloads. It took some fiddling, but I got 'make && make install' to run without any errors. However, when I put Driver "intel" into my xorg.conf, I get "
    (WW) intel: No matching Device section for instance (BusID PCI:0:2:1) found
    (EE) No devices detected.

    Fatal server error:
    no screens found"
    as if the drivers don't support my chipset. Now I'm a bit confused, did the ones I downloaded need a different prefix set for make install? Do I need to get a newer version of X? (I have the latest unmasked x86 from gentoo portage) Do I need to remove something from my kernel in order to make way for the newer intel drivers?
    I noticed in the Xorg.0.log that "Intel Corporation unknown chipset" shows up on both PCI:0:2:1 and :0, I have tried using both in the BusID option.

    Thanks for any input. I have some experience around linux but I still consider myself a newbie.

    My logs can be seen at http://www.ccs.neu.edu/home/brysons/logs/Xorg.0.log and http://www.ccs.neu.edu/home/brysons/logs/xorg.conf

  2. #2
    Just Joined!
    Join Date
    Sep 2006
    Posts
    6

    [resolved]

    The intel driver package was not installing itself to the correct location. A more thorough look at the xorg log made this painfully clear x.x

    Copied it over, and everything worked.

  3. #3
    Just Joined!
    Join Date
    Oct 2008
    Posts
    2
    Do you still have no problem with this setup? Because I got the same motherboard, and the same plan as you with a HTPC.

    I cant run X with acceleration without it crashing after a short while.

    Running xubuntu 8.10 beta, with kernel 2.6.27-5. Intel driver 2.4.2.

    Afaik this is an bug/issue with the intel driver.

  4. #4
    Just Joined!
    Join Date
    Sep 2006
    Posts
    6
    Same here, altho it is a completely separate issue from the one that I initially posted. Hard crash with no logs that I can find after a few minutes of running X. If you don't start X, then it'll run fine (had mine up for 10 days continuously. But within an hour of starting X it dies. I also assume it is a driver bug. I played with the kernel quite a bit and could not improve the situation, so I have sidelined this board until better support arrives.

    I did not file a bug report because I could not find error logs or even come up with any solid method to repeat the issue, just start X... The only thing I noticed was that making the computer use the graphics chip seemed to make it crash faster, eg. playing a video fullscreen while you use the computer.

    I also stress-tested without X running, doing ram tests, kernel re-compile loops etc. to try to make it die without the intel driver loaded, but again, I could not find any other cause than the driver. That is good news tho... support comes with time, and when it does this will be an awesome HTPC board!

  5. #5
    Just Joined!
    Join Date
    Oct 2008
    Posts
    2
    It's usually only my X that's crashing, I can't get up the commandline on my box, after an crash, but my system responds to ssh.

    (I cant get commandline on my box if I quit X myself either, so that is another issue (seen other having the same too))

    Anyways, I think a fix is on its way.

    If you want to read more about it you can check out these threads:
    [ubuntu] Intel GMA X4500HD woes (Intel G45 Chipset) - Ubuntu Forums
    The Official Linux g45 chipset MoBo Thread - AVS Forum
    https://bugs.freedesktop.org/show_bug.cgi?id=17460

    I just hope the fix comes out sooner, rather than later.

  6. #6
    Just Joined!
    Join Date
    Sep 2006
    Posts
    6
    Thanks for the update, good to know that it's out there.

    My box responded to ssh with 'remote host is down' or something like that when I last tried the board, shortly after my first post. So it was alive to some extent, but sshd was not working and I couldn't get any response from the box itself.

    I remember back when I used Ubuntu the screen would get garbled whenever I dropped out of X, but it was an easy fix from a little googling, good luck and hopefully we'll have a solution soon.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •