Find the answer to your Linux question:
Results 1 to 2 of 2
Hello All, When I try to run an X app as root from w/in a terminal window, such as gnome-cups-add, I receive the following error: GnomeUI-WARNING **: While connecting to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2004
    Location
    Sunny Southern California
    Posts
    1

    GNOME - session manager error...host-based authentication


    Hello All,

    When I try to run an X app as root from w/in a terminal window, such as gnome-cups-add, I receive the following error:

    GnomeUI-WARNING **: While connecting to session manager: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed.

    I've googled for a resolution, but the ones I've found have not solved the problem. I've tried:
    1. xhost +localhost as a regular user.
    2. export XAUTHORITY=$HOME/.Xauthority
    3. su user_running_x -c "xauth extract - $DISPLAY" | xauth merge -

    Any help is greatly appreciated. Thank you.

    Jason

  2. #2
    Just Joined!
    Join Date
    Oct 2004
    Posts
    1
    *bump*

    (not bad for a first post, eh)

    christo

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •