Find the answer to your Linux question:
Results 1 to 2 of 2
Hi all I tried to run a simple Swing application on a single board computer running Linux and i've installed xfree86. the x-server runs with no errors. but when i ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    etn
    etn is offline
    Just Joined!
    Join Date
    Nov 2008
    Posts
    2

    [SOLVED] Error running swing on Xfree86


    Hi all
    I tried to run a simple Swing application on a single board computer running Linux and i've installed xfree86. the x-server runs with no errors. but when i run the swing application, it throws error as below...

    Exception in thread "main" java.lang.ArrayIndexOutOfBoundsException: 386
    at java.awt.image.IndexColorModel.setRGBs(Unknown Source)
    at java.awt.image.IndexColorModel.<init>(Unknown Source)
    at sun.awt.X11GraphicsConfig.makeColorModel(Native Method)
    at sun.awt.X11GraphicsConfig.getColorModel(Unknown Source)
    at sun.awt.X11.XWindow.getColorModel(Unknown Source)
    at sun.awt.X11.XWindow.preInit(Unknown Source)
    at sun.awt.X11.XComponentPeer.preInit(Unknown Source)
    at sun.awt.X11.XCanvasPeer.preInit(Unknown Source)
    at sun.awt.X11.XWindowPeer.preInit(Unknown Source)
    at sun.awt.X11.XDecoratedPeer.preInit(Unknown Source)
    at sun.awt.X11.XFramePeer.preInit(Unknown Source)
    at sun.awt.X11.XBaseWindow.init(Unknown Source)
    at sun.awt.X11.XBaseWindow.<init>(Unknown Source)
    at sun.awt.X11.XWindow.<init>(Unknown Source)
    at sun.awt.X11.XComponentPeer.<init>(Unknown Source)
    at sun.awt.X11.XCanvasPeer.<init>(Unknown Source)
    at sun.awt.X11.XPanelPeer.<init>(Unknown Source)
    at sun.awt.X11.XWindowPeer.<init>(Unknown Source)
    at sun.awt.X11.XDecoratedPeer.<init>(Unknown Source)
    at sun.awt.X11.XFramePeer.<init>(Unknown Source)
    at sun.awt.X11.XToolkit.createFrame(Unknown Source)
    at java.awt.Frame.addNotify(Unknown Source)
    at java.awt.Window.show(Unknown Source)
    at java.awt.Component.show(Unknown Source)
    at java.awt.Component.setVisible(Unknown Source)
    at java.awt.Window.setVisible(Unknown Source)
    at Hello.<init>(Hello.java:16)

    I know the error is with X11 since the same swing application runs perfectly on anothter machine running ubuntu...
    Please let me know where it fails...
    Thanks,
    etn

  2. #2
    etn
    etn is offline
    Just Joined!
    Join Date
    Nov 2008
    Posts
    2

    fixed it....

    thanks all...
    i've fixed it by running xf86config.....

    regards,
    etn

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •