Hi.
I have an ATI HD 3200 integrated graphics card.
At first I tried to install the card from ATI's openSUSE 11.1 repository. The card "worked" fine, except openGL wouldn't work. So I uninstalled it, and grabbed the .bin installer from ATI's site instead:

ATI Catalyst™ 9.1 Proprietary Linux x86_64 Display Driver - For Intel® EM64T and AMD64 Platform Architecture

I generated the openSUSE package and installed it. I then ran aticonfig --initial. I rebooted, only to get a black screen with colored bars across it.

I took a look at my xorg.conf file. Unbelievably, the aticonfig script didn't bother to remove the configuration for my previous driver. I commented out the previous configuration, saved it, and restarted X. X now starts, but only because it doesn't load any graphics card driver at all.

I can try to test my driver configuration using YaST, and I get this error message:

screenshot1.jpg

Here is my xorg.conf file. Any help would be greatly appreciated

xorg.conf.txt

Edit: I have confirmed the existence of my 'radeon' driver ('modprobe radeon' and 'modinfo radeon' work fine), so that is not the problem