Find the answer to your Linux question:
Results 1 to 3 of 3
Hi, In an attempt to run call of duty on wine, I've installed a package with drivers for ATI cards. My Laptop (a Dell Latitude D600 with Kubuntu 8.10) has ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2008
    Posts
    15

    [SOLVED] X server failure


    Hi,
    In an attempt to run call of duty on wine, I've installed a package with drivers for ATI cards. My Laptop (a Dell Latitude D600 with Kubuntu 8.10) has an ATI Mobility Radeon 9000 card. I used Adept and looked for something with 'ATI'. I've installed one of the first packages that it showed (I think it was something like this: ATI Linux driver packages for Debian).
    Every time I try to start my computer, this happens:
    -Grub loads, and boots Kubuntu from my harddisk
    -The Kubuntu loadscreen loads almost completely
    -
    *Checking battery state...
    /dev/sda:
    setting Advanced Power Management level to 0xfe (245)
    [ok]
    [ok]
    -The X server starts and shows the x-cursor
    -The screen flashes back to the command-line thing
    -The X server starts and shows the x-cursor
    -The screen flashes back to the command-line thing...
    -... and stays there

    The only thing I can do from now is pressing Alt-F1 and login using the command line. It says:

    Boot from (hd0,0) ext3 c83d...1ef0
    Starting Up...
    Loading, please wait...
    19+0 records in
    19+0 records out
    kinit: name_to_dev_t(/dev/disk/by-uuid/b28b...8d7) = dev(8,5)
    kinit: trying to resume from /dev/disk/by-uuid/b28b...8d7)
    kinit: No resume image, doing normal boot...

    Ubuntu 8.10 teis-laptop tty1
    teis-laptop login:_

    But when i try the command $kinit
    -bash: kinit: command not found

    xinit says:
    xorg-server 2:1.5.2-2ubuntu3 (buildd@rothera.buildd)
    ...
    Module Loader present
    ...
    Backtrace:
    0: X(xf86SigHandler+0x79)
    1: [0xb7f6b400]
    2: /usr/lib/xorg/modules/drivers//radeon_drv.so [0xb79e5c27]
    3: /usr/lib/xorg/modules/drivers//radeon_drv.so [0xb79b355a]
    4: /usr/lib/xorg/modules/drivers//radeon_drv.so [0xb79b64fc]
    5: X(InitOutput+0x279 [0x8071b19]
    6: X(main+0x279) [0x8071b19]
    7: /lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe5) [0xb7b6f685
    8: X [0x8071101]
    Saw signal 11. Server aborting.
    giving up. //this doesnt sound very hopefull
    xinit: Conection refused (errno 111): unable to connect to X server
    xinit: No such process (errno3): server error.

    I hope sombody can help me

  2. #2
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651

  3. #3
    Just Joined!
    Join Date
    Sep 2008
    Posts
    15

    Solved

    I solved the problem.

    I deleted all fglrx packages using aptitude, and everything worked again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •