Find the answer to your Linux question:
Results 1 to 2 of 2
I am running two monitors in a twinview configuration. Yesterday (and before) this was running absolutely perfectly. Screen resolution = 3360 x 1050 Windows draggable between monitors Windows maximized across ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Location
    Either at home or at work or down the pub
    Posts
    3,622

    [SOLVED] Twinview, gnome and compiz


    I am running two monitors in a twinview configuration. Yesterday (and before) this was running absolutely perfectly.

    Screen resolution = 3360 x 1050
    Windows draggable between monitors
    Windows maximized across both monitors
    Gnome panel spanned both monitors
    Compiz effects spanned both monitors (Desktop cube etc)

    Then I shutdown as normal last night and this morning I find that

    Screen resolution = 3360 x 1050
    Windows draggable between monitors
    Windows maximized on an individual monitor
    Gnome panel is only on one monitor
    Compiz effects show on each monitor. So for example I get two cubes.

    I have tried disabling twinview, enabling Xinerama, switching to and from separate X screens, each with a restart of X as and when requested.

    How do I get back to what I had yesterday?

    This is my xorg.conf
    Code:
    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings:  version 1.0  (buildd@vernadsky)  Thu Jun  5 09:26:53 UTC 2008
    
    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "ServerLayout"
        Identifier     "Default Layout"
        Screen      0  "Screen0" 0 0
    EndSection
    
    Section "Module"
        Load           "glx"
    EndSection
    
    Section "ServerFlags"
    
    # Removed Option "Xinerama" "0"
    # Removed Option "Xinerama" "1"
        Option         "Xinerama" "0"
    EndSection
    
    Section "InputDevice"
        Identifier     "Generic Keyboard"
        Driver         "kbd"
        Option         "XkbRules" "xorg"
        Option         "XkbModel" "pc105"
        Option         "XkbLayout" "gb"
    EndSection
    
    Section "InputDevice"
        Identifier     "Configured Mouse"
        Driver         "mouse"
        Option         "CorePointer"
        Option         "Emulate3Buttons" "true"
    EndSection
    
    Section "Monitor"
        Identifier     "Configured Monitor"
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "LG L225W"
        HorizSync       28.0 - 83.0
        VertRefresh     56.0 - 75.0
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor1"
        VendorName     "Unknown"
        ModelName      "Samsung SyncMaster"
        HorizSync       30.0 - 81.0
        VertRefresh     56.0 - 75.0
    EndSection
    
    Section "Device"
        Identifier     "Configured Video Device"
        Driver         "nvidia"
        Option         "NoLogo" "True"
    EndSection
    
    Section "Device"
        Identifier     "Videocard0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 8600 GT"
    EndSection
    
    Section "Device"
        Identifier     "Videocard1"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 8600 GT"
        BusID          "PCI:1:0:0"
        Screen          1
    EndSection
    
    Section "Screen"
        Identifier     "Default Screen"
        Device         "Configured Video Device"
        Monitor        "Configured Monitor"
        DefaultDepth    24
    EndSection
    
    Section "Screen"
    
    # Removed Option "metamodes" "CRT: nvidia-auto-select +1680+0, DFP: nvidia-auto-select +0+0; CRT: 1440x900_60 +0+0, DFP: NULL; CRT: 1440x900_60_0 +0+0, DFP: NULL; CRT: 1400x1050 +0+0, DFP: NULL; CRT: 1280x1024 +0+0, DFP: NULL; CRT: 1280x1024_60 +0+0, DFP: NULL; CRT: 1280x960 +0+0, DFP: NULL; CRT: 1280x800 +0+0, DFP: NULL; CRT: 1280x768 +0+0, DFP: NULL; CRT: 1152x864 +0+0, DFP: NULL; CRT: 1024x768 +0+0, DFP: NULL; CRT: 1024x768_70 +0+0, DFP: NULL; CRT: 1024x768_60 +0+0, DFP: NULL; CRT: 832x624 +0+0, DFP: NULL; CRT: 800x600 +0+0, DFP: NULL; CRT: 800x600_72 +0+0, DFP: NULL"
    # Removed Option "TwinView" "1"
    # Removed Option "metamodes" "CRT: 1680x1050 +1680+0, DFP: 1680x1050 +0+0; CRT: 1440x900_60 +0+0, DFP: NULL; CRT: 1440x900_60_0 +0+0, DFP: NULL; CRT: 1400x1050 +0+0, DFP: NULL; CRT: 1280x1024 +0+0, DFP: NULL; CRT: 1280x1024_60 +0+0, DFP: NULL; CRT: 1280x960 +0+0, DFP: NULL; CRT: 1280x800 +0+0, DFP: NULL; CRT: 1280x768 +0+0, DFP: NULL; CRT: 1152x864 +0+0, DFP: NULL; CRT: 1024x768 +0+0, DFP: NULL; CRT: 1024x768_70 +0+0, DFP: NULL; CRT: 1024x768_60 +0+0, DFP: NULL; CRT: 832x624 +0+0, DFP: NULL; CRT: 800x600 +0+0, DFP: NULL; CRT: 800x600_72 +0+0, DFP: NULL"
    # Removed Option "TwinView" "0"
    # Removed Option "metamodes" "DFP: 1680x1050 +0+0"
        Identifier     "Screen0"
        Device         "Videocard0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "TwinView" "1"
        Option         "TwinViewXineramaInfoOrder" "DFP-0"
        Option         "metamodes" "CRT: nvidia-auto-select +1680+0, DFP: 1680x1050 +0+0"
    EndSection
    "I used to be with it, then they changed what it was.
    Now what was it isn't it, and what is it is weird and scary to me.
    It'll happen to you too."

    Grandpa Simpson



    The Fifth Continent

  2. #2
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Location
    Either at home or at work or down the pub
    Posts
    3,622
    Got It!

    I stopped trying to use the configuration tool and added two simple lines into my xorg.conf. OIne quick Ctrl + Alt + Backspace later and all is well

    Code:
    Section "Screen"
    
    # Removed Option "metamodes" "CRT: nvidia-auto-select +1680+0, DFP: nvidia-auto-select +0+0; CRT: 1440x900_60 +0+0, DFP: NULL; CRT: 1440x900_60_0 +0+0, DFP: NULL; CRT: 1400x1050 +0+0, DFP: NULL; CRT: 1280x1024 +0+0, DFP: NULL; CRT: 1280x1024_60 +0+0, DFP: NULL; CRT: 1280x960 +0+0, DFP: NULL; CRT: 1280x800 +0+0, DFP: NULL; CRT: 1280x768 +0+0, DFP: NULL; CRT: 1152x864 +0+0, DFP: NULL; CRT: 1024x768 +0+0, DFP: NULL; CRT: 1024x768_70 +0+0, DFP: NULL; CRT: 1024x768_60 +0+0, DFP: NULL; CRT: 832x624 +0+0, DFP: NULL; CRT: 800x600 +0+0, DFP: NULL; CRT: 800x600_72 +0+0, DFP: NULL"
    # Removed Option "TwinView" "1"
    # Removed Option "metamodes" "CRT: 1680x1050 +1680+0, DFP: 1680x1050 +0+0; CRT: 1440x900_60 +0+0, DFP: NULL; CRT: 1440x900_60_0 +0+0, DFP: NULL; CRT: 1400x1050 +0+0, DFP: NULL; CRT: 1280x1024 +0+0, DFP: NULL; CRT: 1280x1024_60 +0+0, DFP: NULL; CRT: 1280x960 +0+0, DFP: NULL; CRT: 1280x800 +0+0, DFP: NULL; CRT: 1280x768 +0+0, DFP: NULL; CRT: 1152x864 +0+0, DFP: NULL; CRT: 1024x768 +0+0, DFP: NULL; CRT: 1024x768_70 +0+0, DFP: NULL; CRT: 1024x768_60 +0+0, DFP: NULL; CRT: 832x624 +0+0, DFP: NULL; CRT: 800x600 +0+0, DFP: NULL; CRT: 800x600_72 +0+0, DFP: NULL"
    # Removed Option "TwinView" "0"
    # Removed Option "metamodes" "DFP: 1680x1050 +0+0"
        Identifier     "Screen0"
        Device         "Videocard0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "TwinViewXineramaInfoOrder" "DFP-0"
        Option         "metamodes" "CRT: nvidia-auto-select +1680+0, DFP: 1680x1050 +0+0"
    EndSection
    becomes

    Code:
    Section "Screen"
    
    # Removed Option "metamodes" "CRT: nvidia-auto-select +1680+0, DFP: nvidia-auto-select +0+0; CRT: 1440x900_60 +0+0, DFP: NULL; CRT: 1440x900_60_0 +0+0, DFP: NULL; CRT: 1400x1050 +0+0, DFP: NULL; CRT: 1280x1024 +0+0, DFP: NULL; CRT: 1280x1024_60 +0+0, DFP: NULL; CRT: 1280x960 +0+0, DFP: NULL; CRT: 1280x800 +0+0, DFP: NULL; CRT: 1280x768 +0+0, DFP: NULL; CRT: 1152x864 +0+0, DFP: NULL; CRT: 1024x768 +0+0, DFP: NULL; CRT: 1024x768_70 +0+0, DFP: NULL; CRT: 1024x768_60 +0+0, DFP: NULL; CRT: 832x624 +0+0, DFP: NULL; CRT: 800x600 +0+0, DFP: NULL; CRT: 800x600_72 +0+0, DFP: NULL"
    # Removed Option "TwinView" "1"
    # Removed Option "metamodes" "CRT: 1680x1050 +1680+0, DFP: 1680x1050 +0+0; CRT: 1440x900_60 +0+0, DFP: NULL; CRT: 1440x900_60_0 +0+0, DFP: NULL; CRT: 1400x1050 +0+0, DFP: NULL; CRT: 1280x1024 +0+0, DFP: NULL; CRT: 1280x1024_60 +0+0, DFP: NULL; CRT: 1280x960 +0+0, DFP: NULL; CRT: 1280x800 +0+0, DFP: NULL; CRT: 1280x768 +0+0, DFP: NULL; CRT: 1152x864 +0+0, DFP: NULL; CRT: 1024x768 +0+0, DFP: NULL; CRT: 1024x768_70 +0+0, DFP: NULL; CRT: 1024x768_60 +0+0, DFP: NULL; CRT: 832x624 +0+0, DFP: NULL; CRT: 800x600 +0+0, DFP: NULL; CRT: 800x600_72 +0+0, DFP: NULL"
    # Removed Option "TwinView" "0"
    # Removed Option "metamodes" "DFP: 1680x1050 +0+0"
        Identifier     "Screen0"
        Device         "Videocard0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "TwinView" "1"
        Option         "Xinerama" "1"
        Option         "TwinViewXineramaInfoOrder" "DFP-0"
        Option         "NoTwinViewXineramaInfo"     "True"
        Option         "metamodes" "CRT: nvidia-auto-select +1680+0, DFP: 1680x1050 +0+0"
    EndSection
    You truly haven't seen funky until you see the desktop cube spanning multiple monitors at a ridiculous resolution.
    "I used to be with it, then they changed what it was.
    Now what was it isn't it, and what is it is weird and scary to me.
    It'll happen to you too."

    Grandpa Simpson



    The Fifth Continent

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •