Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
I cant write to my fat32 windows hard drive. i have it mounted, and can read from it perfectly fine, but i can only write to it when i am ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2002
    Posts
    1

    Problems with writing to a mounted windows fat32 partition


    I cant write to my fat32 windows hard drive. i have it mounted, and can read from it perfectly fine, but i can only write to it when i am on as the root user. When logged on as the root, i try to change the group or the owner of it by changing the settings under the permissions tab on the drive properties, but it wont let me change any settings, saying i do not have the permissions neccessary to change the settings. I dont get it, i am logged on as root and it says the owner and group of the drive is root... i think it may be a prob with how i am telling linux to mount it. this is the string i put in the "/etc/fstab" file:

    /dev/hde1 /mnt/Storage vfat auto,owner,users 0 0

    Any help would be great, thanks!!

    also, i know this is a dumb question, but how do i get the "numlock" key to be turned on (make it default to be on) every time my system boots??

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Remove the 'owner' entry and try it again. 'owner' specifies that only the owner of the device (/dev/hde1) may mount it, while 'users' specifies that anyone may mount and unmount it. It might be that they are conflicting with each other.
    Study fstab(5) and mount( for more options. I would probably use it as noauto,owner and add /dev/hde1 to /etc/security/console.perms, but that might just be me.

  3. #3
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    The cool smily was supposed to be 8), as in mount(8)
    It's almost starting to annoy me.

  4. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    By the way, is there a way to turn on NumLock when you log in? That has puzzled me for a while, as well. On the other hand, I've never actually checked on it.

  5. #5
    Just Joined! Sykotik's Avatar
    Join Date
    Mar 2002
    Location
    Cape Town, South Africa
    Posts
    54
    Another thing you might try is umask=000. Gives rwx to all users.

    --Syk

  6. #6
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Hmmm... that could also work... I feel kind of stupid now.

  7. #7
    Just Joined! Sykotik's Avatar
    Join Date
    Mar 2002
    Location
    Cape Town, South Africa
    Posts
    54
    Quote Originally Posted by Dolda2000
    Hmmm... that could also work...
    It does work
    I use it on my other machine (Windows/Linux dual boot). Works like a charm, and it's only trusted users on the machine so I don't care if it's rwxrwxrwx

  8. #8
    Linux User
    Join Date
    Nov 2002
    Posts
    420
    yu can change the default NumLock status through your bios setup.
    check out your bios setup.


    --braincode

  9. #9
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Yes, well the BIOS can only control the NumLock at boot time. The thing is that mingetty and X turns it off as soon as you log in (actually, when they are started, which is often quite the same, though).
    Of course it is possible to change it in the source. I just think that there should be some more high-level way of doing it.

  10. #10
    Just Joined!
    Join Date
    Sep 2002
    Location
    Massachusetts, USA
    Posts
    4
    If you are running KDE:

    1. go to the control center
    2. select peripherals on the right hand side
    3. select keyboard
    4. click on the advanced tab, and
    5. you will see the numlock settings. "Turn On" will make it stay on all the time--my setting.

    If you are running GNOME:

    1. read the manual, and
    2. post it to this thread ;^)

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •