Find the answer to your Linux question:
Results 1 to 7 of 7
I'm using Gentoo and KDE 4.2.3 and I also have Xfce4 installed. My problem is, when I'm using KDE and I try opening anything with Dolphin file manager, Thunar opens ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864

    Thunar takes over Dolphin (SOLVED)


    I'm using Gentoo and KDE 4.2.3 and I also have Xfce4 installed. My problem is, when I'm using KDE and I try opening anything with Dolphin file manager, Thunar opens instead. This happens even if I insert a Data DVD and select open with Dolphin. I know I did not set this to happen, so I really don't know why it's doing it or how to change it. Anyone else had this problem?
    Last edited by MikeTbob; 05-11-2009 at 04:00 AM.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  2. #2
    Linux User saivin's Avatar
    Join Date
    Dec 2008
    Location
    Bengaluru, India
    Posts
    305
    Hi Mike,
    Did you install Xfce after KDE? Is it possible that during such install the default application for file management changed to Thunar from Dolphin?
    A candle looses nothing by lighting other candles. - Khalil Zibran.
    Registered Linux User #490076

  3. #3
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Yes, that is what happened apparently, I have found a few links that point to very similar problems, such as Thunar taking over Nautilus, but I haven't found the answer that works for me.
    https://bugs.launchpad.net/thunar/+bug/35997
    This is an old bug, but if you see the comments, users are still having problems with it in 2009. I tried a couple of the suggestions in the comments sections and it hasn't changed anything yet. I'll keep looking because this is really annoying for me. Thanks.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  4. $spacer_open
    $spacer_close
  5. #4
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Hi, Mike

    Sorry I don't have a fix to offer up, but it's things like this is why I've never liked to mix desktop enviroments on the same system. It seems like each DE wants to be in control of the system, and sometimes the weirdness can be really hard to track down, or it might not even show up for weeks, or months down the road.

    Hope you are able to find a simple solution.
    oz

  6. #5
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Hiya ozar and Thanks.
    I did manage to find a setting within KDE4 system-settings>Default Applications>File Manager. It was set to "Open folders with Thunar", I can change that to Nautilus but not Dolphin....strange, you'd think it would have Dolphin listed as a file manager.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  7. #6
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864

    Bump!

    A bump for hope.
    *crosses fingers*
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  8. #7
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Ok, this has been solved. Apparently Dolphin was never installed to begin with. I installed Konqueror and that worked as a file manager, so I just got curious and tried to launch Dolphin from the command line:
    Code:
    Dolphin: command not found
    So I just installed Dolphin
    Code:
    emerge -1 kde-base/dolphin:4.2
    I was under the impression that Dolphin was an integral part of KDE and would be included in the base install of KDE.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •