Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
I'm running fedora core 2 and I cannot get the desktop swithcer to make KDE my default. I open it up, select kde restart x session and open it back ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2004
    Posts
    7

    I am Going Insane - desktop


    I'm running fedora core 2 and I cannot get the desktop swithcer to make KDE my default. I open it up, select kde restart x session and open it back up and it still has gnome selected. So when I log out of KDE, the logout menu just displays 'end session' instead of the other options of restart, shutdown etc.

    This is annoying the living @#$% out of me, what can I do to stop this?

    Tanks!!!

  2. #2
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    You could create a text file in your home directory named .xinitrc (note the period), and give it this line:

    Code:
    exec startkde
    Of course, this is assuming you have KDE installed in the first place. I don't think FC2 installs it by default.
    Registered Linux user #270181
    TechieMoe's Tech Rants

  3. #3
    Just Joined!
    Join Date
    Oct 2004
    Posts
    7
    Quote Originally Posted by techieMoe
    You could create a text file in your home directory named .xinitrc (note the period), and give it this line:

    Code:
    exec startkde
    Of course, this is assuming you have KDE installed in the first place. I don't think FC2 installs it by default.
    It's installed and I can run it. The real irritation is that when I want to shut down while in KDE, I don't have my normal menu available. All I get is "end session for user?" instead of

    logout
    reboot
    shutdown

    maybe I'm identifying the problem incorrectly but i thought you solved this with the desktop switcher. Everytime I open it up, gnome is selected, even though I'm running kde... it's a small thing but it is driving me nuts!!! Everytime I select KDE as the default, the damn thing switches it back to gnome next time i startup.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    Quote Originally Posted by cochisetx
    It's installed and I can run it. The real irritation is that when I want to shut down while in KDE, I don't have my normal menu available. All I get is "end session for user?" instead of

    logout
    reboot
    shutdown
    I usually get this problem when I don't boot into runlevel 5 by default. I have no idea if that's your problem however.

    maybe I'm identifying the problem incorrectly but i thought you solved this with the desktop switcher. Everytime I open it up, gnome is selected, even though I'm running kde... it's a small thing but it is driving me nuts!!!
    AFAIK, the desktop switcher generates an .xinitrc file with the appropriate "exec" line just as I outlined above, and that's all it does. As far as what DE it chooses by default, I don't know how to help you there. That may very well be Fedora's doing, since it's Gnome-centric now.
    Registered Linux user #270181
    TechieMoe's Tech Rants

  6. #5
    Just Joined!
    Join Date
    Oct 2004
    Posts
    7
    Quote Originally Posted by techieMoe
    Quote Originally Posted by cochisetx
    It's installed and I can run it. The real irritation is that when I want to shut down while in KDE, I don't have my normal menu available. All I get is "end session for user?" instead of

    logout
    reboot
    shutdown
    I usually get this problem when I don't boot into runlevel 5 by default. I have no idea if that's your problem however.

    maybe I'm identifying the problem incorrectly but i thought you solved this with the desktop switcher. Everytime I open it up, gnome is selected, even though I'm running kde... it's a small thing but it is driving me nuts!!!
    AFAIK, the desktop switcher generates an .xinitrc file with the appropriate "exec" line just as I outlined above, and that's all it does. As far as what DE it chooses by default, I don't know how to help you there. That may very well be Fedora's doing, since it's Gnome-centric now.
    Yes, it is Fedora doing it. I wish someone knew how to change this. I am a noob.

  7. #6
    Just Joined!
    Join Date
    Jul 2004
    Location
    Wherever the beautiful women are.
    Posts
    99
    I don't know if this is the same for Fedora, but in Slackware there is a file called inittab, where you can set things such as runlevels. At the the point in the file where you do that, add the path of the executable file which starts up KDE.

    Hope this helps.

  8. #7
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    Yes, Fedora has /etc/inittab. I've used it before to edit the runlevel. I wasn't aware it had references to the X environment in it though... (I guess it makes sense.. runlevel 5 is boot with X)
    Registered Linux user #270181
    TechieMoe's Tech Rants

  9. #8
    Linux Engineer
    Join Date
    Aug 2004
    Posts
    826

    Re: I am Going Insane - desktop

    Quote Originally Posted by cochisetx
    I'm running fedora core 2 and I cannot get the desktop swithcer to make KDE my default. I open it up, select kde restart x session and open it back up and it still has gnome selected.
    regarding this question, fedora has a neat little utility that'll allow you to do this. just login to kde, and search the K menu (i can't remember the exact location and name of the utility). it's something like "desktop switching" or "default desktop" or something. open it up and tell it you want kde as the default.

    edit: oh wait, i just realized you already tried that. are you sure that's the correct utility, cause there might be another one? and what does it say in .xinitrc? why can't you just uninstall gnome through the package manager in fedora, if you aren't going to use it?

  10. #9
    Linux Engineer
    Join Date
    Sep 2003
    Location
    Knoxhell, TN
    Posts
    1,078
    GNOME and KDE are both ridiculously difficult to eradicate from a system because they are collections of various utilities and applications.. most GNOME and KDE "packages" are actually dummy packages that depend upon everything needed for what most people think of as "GNOME" and "KDE"...

    as far as what DE/WM is default, check [KDM|GDM|XDM|Entrance]'s config file... it should actually be there. not inittab or .xinitrc.
    Their code will be beautiful, even if their desks are buried in 3 feet of crap. - esr

  11. #10
    GGG
    GGG is offline
    Just Joined!
    Join Date
    Nov 2004
    Location
    Germany
    Posts
    1
    Hi,
    I had the same problem, after I have finished a mimimum-size SUSE9.1 Installation: At logout I only got "End session for "user"" and not the selection out of the three End session / Turn off computer / Restart computer.

    After I added the module kde3base-kdm (YAST-->Install software), I got a more colourful login screen AND the old logoff selection.

    BTW: In KDE --> Control Center --> KDE Components --> Session Manager and in
    YAST --> Security & Users --> Security Settings-->Custom Settings --> Next --> Next --> Boot Permissions
    you can select some default settings resp. some restrictions.

    Does it help?
    It took me a complete night to find out .
    GGG

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •