Find the answer to your Linux question:
Results 1 to 6 of 6
I have a Toshiba Satellite and installed Mandrake 9.0 on it. With some help from this forum (thanks again, Dolda), I got the X server to work. Now I'm trying ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2003
    Posts
    7

    USB mouse in an Toshiba notebook


    I have a Toshiba Satellite and installed Mandrake 9.0 on it. With some help from this forum (thanks again, Dolda), I got the X server to work.

    Now I'm trying to configure a USB wheel mouse. The built in touch pad mouse works fine, but the USB mouse is dead. I move the mouse and the pointer is dead.

    Tried with mouseconfig, selected USB wheel and nothing happened.

    Any help will be appreciated

    Thanks in advance

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Try configuring your mouse as a USB mouse again, then check your /etc/X11/XF86Config. If that file is correctly configured for your USB mouse (the fault may lie elsewhere), it should have at least one Mouse InputDevice sections where the "Device" option reads "/dev/input/mice".

  3. #3
    Linux Engineer
    Join Date
    Apr 2003
    Location
    Sweden
    Posts
    796
    Also make sure that you have the usb-support enabled in bios.

    regards

    Regards

    Andutt

  4. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    That shouldn't be necessary. Except for APM, Linux doesn't use the BIOS once it has booted completely.

  5. #5
    Linux Newbie
    Join Date
    Apr 2003
    Location
    Pontypridd, Wales
    Posts
    104
    How about trying this. Ok. In your XF86Config file add the section below starting Identifier Section "InputDevice".

    One you've done this add the line:

    InputDevice "DevInputMice" "AlwaysCore"

    to your Server layout, so it looks like the example below.

    Make sure that Mouse0 is actually set up as a USB mouse as well.

    I have no idea if this will solve your problem, but there should be no harm in trying!

    nomar.

    Section "ServerLayout"
    Identifier "Default Layout"
    Screen 0 "Screen0" 0 0
    InputDevice "Mouse0" "CorePointer"
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "DevInputMice" "AlwaysCore"
    EndSection

    Section "InputDevice"
    # If the normal CorePointer mouse is not a USB mouse then
    # this input device can be used in AlwaysCore mode to let you
    # also use USB mice at the same time.
    Identifier "DevInputMice"
    Driver "mouse"
    Option "Protocol" "IMPS/2"
    Option "Device" "/dev/input/mice"
    Option "ZAxisMapping" "4 5"
    Option "Emulate3Buttons" "no"
    EndSection
    \"One World, One Web, One Program.\" -- Advertisement for Internet Explorer.
    \"Ein Volk, Ein Reich, Ein Fuehrer.\" -- Adolf Hitler.

  6. #6
    Just Joined!
    Join Date
    May 2003
    Posts
    15
    I had a similar problem. Like a dumbass I left my mouse connected to my laptop while I was installing RH9 and it didn't detect my touch pad correctly. So I had to go into Applications>System Settings > Mouse and select the ALPS Glidepoint (PS/2) and now all my "Mice" work correctly.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •