Find the answer to your Linux question:
Results 1 to 4 of 4
I have a desktop that has been installed & running linux very well for about 2 years, with intel graphics & a TFT screen. After a recent software update, with ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2009
    Posts
    1

    Xwindows very slow since recent update


    I have a desktop that has been installed & running linux very well for about 2 years, with intel graphics & a TFT screen. After a recent software update, with no hardware changes and retaining the old xorg.conf, X11 graphics performance has seriously slowed down. Switching between 2 full-screen X applications can take seconds to fully display.

    The system's running Debian unstable with the following
    kernel 2.6.26, xorg 7.4
    00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02)

    I'm currently using the intel drivers in Xorg, if I reboot to use the intel framebuffer (video=intelfb:mode=1024x768-16) the framebuffer only loads at 640x480.

    I've tried removing the xorg.conf file & booting from a few recent live CDs, but they don't help. The automatic X setup selects modes out-of-range for the monitor so that powers off, and using a framebuffer with any of them only gives a 640x480 display

    I can't upgrade the kernel, this system locks hard if running 2.6.30.

    xorg.conf
    Code:
    Section "ServerLayout"
      Identifier     "Default Layout"
      Screen         "Default Screen"
      InputDevice    "Generic Keyboard"
      InputDevice    "Configured Mouse"
    EndSection
    
    Section "Files"
    
      # path to defoma fonts
      FontPath     "/usr/share/fonts/X11/misc"
      FontPath     "/usr/X11R6/lib/X11/fonts/misc"
      FontPath     "/usr/share/fonts/X11/cyrillic"
      FontPath     "/usr/X11R6/lib/X11/fonts/cyrillic"
      FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
      FontPath     "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
      FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
      FontPath     "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
      FontPath     "/usr/share/fonts/X11/Type1"
      FontPath     "/usr/X11R6/lib/X11/fonts/Type1"
      FontPath     "/usr/share/fonts/X11/100dpi"
      FontPath     "/usr/X11R6/lib/X11/fonts/100dpi"
      FontPath     "/usr/share/fonts/X11/75dpi"
      FontPath     "/usr/X11R6/lib/X11/fonts/75dpi"
      FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    EndSection
    
    Section "Module"
      Load  "bitmap"
      Load  "ddc"
      Load  "dri"
      Load  "extmod"
      #Load  "freetype"
      Load  "glx"
      Load  "int10"
      Load  "vbe"
      #Load  "shm"
    EndSection
    
    Section "InputDevice"
      Identifier  "Generic Keyboard"
      Driver      "kbd"
      Option      "CoreKeyboard"
      Option      "XkbRules" "xorg"
      Option      "XkbModel" "pc105"
      Option      "XkbLayout" "gb"
    EndSection
    
    Section "InputDevice"
      Identifier  "Configured Mouse"
      Driver      "mouse"
      Option      "CorePointer"
      Option      "Device" "/dev/input/mice"
      Option      "Protocol" "ImPS/2"
    EndSection
    
    Section "Monitor"
      Identifier   "Generic Monitor"
    EndSection
    Section "Device"
      Identifier  "ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500]"
      Driver      "intel"
      BusID       "PCI:0:2:0"
      #Driver   "fbdev"
    EndSection
    
    Section "Screen"
      Identifier "Default Screen"
      Device     "ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500]"
      Monitor    "Generic Monitor"
      DefaultDepth     16
      SubSection "Display"
        Depth     1
        Modes    "1024x768" "800x600" "640x480"
      EndSubSection
      SubSection "Display"
        Depth     4
        Modes    "1024x768" "800x600" "640x480"
      EndSubSection
      SubSection "Display"
        Depth     8
        Modes    "1024x768" "800x600" "640x480"
      EndSubSection
      SubSection "Display"
        Depth     15
        Modes    "1024x768" "800x600" "640x480"
      EndSubSection
      SubSection "Display"
        Depth     16
        #Modes    "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
        Modes    "1024x768" "800x600" "640x480"
      EndSubSection
      SubSection "Display"
        Depth     24
        Modes    "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
      EndSubSection
    EndSection
    
    Section "DRI"
      Mode         0666
    EndSection

  2. #2
    Linux Newbie sarlacii's Avatar
    Join Date
    May 2005
    Location
    South Africa
    Posts
    110
    Hey Patter... have you had a look at dmesg and your X logs for errors? If not, that may be where to start.
    Else, run top in a terminal when you change apps and look to see if something other than X is hogging CPU cycles.
    It's just a start.
    If you could also post exactly what was included in your "software update", that could help... since you report that is was only after the update that things went pear-shaped. Did you upgrade your entire distro? Or was is just a new application with some dependancies that you installed?
    Thanks.
    Respectfully... Sarlac II
    ~~
    The moving clock K' appears to K to run slow by the factor (1-v^2/c^2)^(1/2).
    This is the phenomenon of time dilation.
    The faster you run, the younger you look, to everyone but yourself.

  3. #3
    Just Joined!
    Join Date
    Sep 2009
    Posts
    1
    Hi

    Have you solved your problem. I have exactly the same.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    It's most likely the intel graphics drivers causing the problem.

    These are Ubuntu guides but should be basically applicable.

    New Ubuntu Intel Graphics Drivers ~ Web Upd8

    Intel Graphics Performance Guide for Ubuntu 9.04 (Jaunty) Users|Ubuntu Geek

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •