Find the answer to your Linux question:
Results 1 to 1 of 1
Hi all, here's my problem: I use gnome's sound-juicer to create my audio mp3s and had configured some gstreamer pipelines for this purpose. So in sound-juicer I could go to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Sep 2007
    Posts
    164

    [SOLVED] Where are GNOME's default GStreamer pipelines configured?


    Hi all,

    here's my problem: I use gnome's sound-juicer to create my audio mp3s and had
    configured some gstreamer pipelines for this purpose. So in sound-juicer I could go to
    Edit → Preferences and select my Output Format from the drop-down list.

    Now I have updated my system (Debian etch to lenny), and I find a new, strange
    set of output formats. When I hit Edit Profiles in sound-juicer it brings up a dialog
    with my old output formats.

    So my problem is: the old settings seem to be still there, but they don't show up
    in sound-juicers drop-down option box.

    Can some-one tell me what is going on?
    It what also help, if I could find the place where GStreamer pipelines are
    configured for all of Gnome.

    cheers, kai

    EDIT:
    I managed to fix this myself, found this hint on another website:
    Profiles will not be displayed if the GStreamer pipeline is invalid. For example, if you try to ogg-encode an integer stream it will be invalid and be removed from the visible list. Similarly, if you don't have the libraries that will make a given pipeline element work, such as using lame in a pipeline without having LAME installed.
    In my case I had to install the gstreamer0.10-lame debian package.
    Last edited by kai12; 09-15-2009 at 01:26 PM. Reason: solved

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •