Find the answer to your Linux question:
Results 1 to 4 of 4
Wow... My disk went 100% full yesterday during an update of the OS (fedora 11) and after getting "disk full", I've delete some files and update finished "successfully". But when ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2009
    Posts
    2

    [SOLVED] Application part of the GNome menu is lost


    Wow... My disk went 100% full yesterday during an update of the OS (fedora 11) and after getting "disk full", I've delete some files and update finished "successfully". But when I clicked on the Gnome Menu, there were only SYSTEM, PLACES, Logout, Lock and Shutdown. I am missing APPLICATIONS menu.

    I've tried many different things, reinstalling gnome-panel and gnome-applets, reinstalling gnome-desktop; running "alacarte" (which shows applications correctly but does not has any effect on the actual menu).

    Can somebody suggest something?

    Oh.. one more point. When I press Alt+F2, it crashes. Maybe it wants to read something from menu file or something...

  2. #2
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Welcome to the forums!

    If you aren't sure about what all you might have deleted, I'd recommend doing a fresh install, but only after reworking the partitions a bit to make sure that there is adequate room on each of them this time. The reason for the fresh install is that you could keep running into problems for quite some time with the current install, and a fresh install might be faster in the long run than continually having to figure out what is missing.

    Just my own opinion, of course.
    oz

  3. #3
    Linux Engineer Thrillhouse's Avatar
    Join Date
    Jun 2006
    Location
    Arlington, VA, USA
    Posts
    1,377
    Simply uninstalling and reinstalling Gnome might do the trick w/o having to do a full re-install of the OS. Try removing and then installing the Gnome desktop meta-package. Be sure to go over the programs it's trying to remove, though. Sometimes Gnome will try and take with it packages that aren't really related to the desktop, calling them "dependencies." Make sure you note these and re-install them when you get Gnome back on there.
    Code:
    #yum remove gnome-desktop
    #yum install gnome-desktop

  4. #4
    Just Joined!
    Join Date
    Sep 2009
    Posts
    2
    Thrillhouse, I've did that too with no effect on menus. At last, I made another used and she had all the menus; result: something is wrong in moy home directory.

    I've erased many things with no success and at the end deleting some dirs from .local, solved the problem (and reseted many many other things in gnome). Since I was deleting 5 dirs ( .something) each time, I can not tell exactly whith was controlling this menu thing but the problem is solved.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •