Find the answer to your Linux question:
Results 1 to 4 of 4
Hello there, i'm a newbie to ubuntu. I wanna ask, after installation of nvidia driver, my ubuntu crash and cannot log into normal mode and for i've been doing a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2009
    Posts
    1

    Exclamation <HELP> Xorg crash after installing Nvidia driver


    Hello there, i'm a newbie to ubuntu. I wanna ask, after installation of nvidia driver, my ubuntu crash and cannot log into normal mode and for i've been doing a lot of things in recovery mode to fix this problem. But still not working

    Here my xorg.conf
    Code:
    Section "Screen"
    	Identifier	"Default Screen"
    	DefaultDepth	24
    	Option	"AddARGBGLXVisuals"	"True"
    EndSection
    
    Section "Module"
    	Load	"glx"
    EndSection
    
    COuld someone help me please,,,,
    
    Section "Device"
    	Identifier	"Default Device"
    	Driver	"nvidia"
    	Option	"NoLogo"	"True"
    EndSection
    and some code of my xorg.0.log
    Code:
    ..
    (II) Module dri2: vendor="X.Org Foundation"
    	compiled for 1.6.4, module version = 1.1.0
    	ABI class: X.Org Server Extension, version 2.0
    (II) Loading extension DRI2
    (II) LoadModule: "nvidia"
    (WW) Warning, couldn't open module nvidia
    (II) UnloadModule: "nvidia"
    (EE) Failed to load module "nvidia" (module does not exist, 0)
    (EE) No drivers available.
    
    Fatal server error:
    no screens found
    
    ..

  2. #2
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Hello and Welcome.
    Just to get things working for now, you can change the Driver to Vesa, in /etc/X11/xorg.conf
    Then I would consider re-installing the NVIDIA driver.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  3. #3
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    Did you install nvidia driver through hardware drivers menu? What is your graphics card? Open terminal and execute this
    Code:
    lspci | grep -i vga

  4. #4
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, or in a galaxy far, far away.
    Posts
    11,158
    From the error log it seems that the system cannot load the nvidia kernel module. That usually means that it was either not installed properly, or you have tried to install the wrong driver, such as a 32-bit driver in a 64-bit system, or vice-versa. You need to boot into text mode, download the correct driver file from nVidia for your system, and run the installation script, confirming it when the script asks if you want it to update the Xorg.conf file.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •