Find the answer to your Linux question:
Results 1 to 6 of 6
Hi everyone, new to the forums, hoping you could help out. I have Ubuntu server installed and wish to know how to start Firefox automatically after the login. This is ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! GetToDaChopa's Avatar
    Join Date
    Nov 2009
    Posts
    4

    Start Firefox Instead of Gnome/KDE on boot.


    Hi everyone, new to the forums, hoping you could help out.

    I have Ubuntu server installed and wish to know how to start Firefox automatically after the login. This is with out a GUI, i want it to load X Window and then launch Firefox bypassing the Gnome/KDE etc Windows Managers. i can always type it in to launch it but want it to do it automatically.

    The other issue is that the resolution is not that great after i start firefox and would like to know how to make to at least 1024x etc.. to 1280x etc screen resolution. I've played around with the xorg.conf file and no luck so far.

    Thank you for any help you may provide .

  2. #2
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Some helpful ideas here.

    I don't believe Ubuntu uses /etc/inittab, but Method 3 ought to work fine.

    Once you edit your ~/.bash_profile to run startx at login, you'll want to edit ~/.xinitrc to run whatever programs you want to run.

    man page xinit section 1
    man page startx section 1

    As for your screen resolution, if I had to hazard a guess, I would assume you do not have the driver for your video card installed, since you're running a server, and are using the generic vesa driver. It may be installing the correct driver will allow the autoconfiguration stuff to properly detect your screen res.

    Otherwise, you will need to create a working xorg.conf file. If you post it, someone may be able to help, though I'm not too knowledgeable about the specifics.
    X11 Configuration

  3. #3
    Just Joined! GetToDaChopa's Avatar
    Join Date
    Nov 2009
    Posts
    4
    Thanks for that. I'll try it this evening when i get back from work and post up the results. It's running in a virtual machine right now, maybe i'll try and install the drivers that come with it.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined! GetToDaChopa's Avatar
    Join Date
    Nov 2009
    Posts
    4
    Ok so this is what worked for me.

    Created the file: ~/.bash_profile

    With this content:

    Code:
    if [[ -z "$DISPLAY" ]] && [[ $(tty) = /dev/etc1 ]]; then
    xinit
    fi
    Then created: ~/.xinitrc

    With this content:

    Code:
    firefox
    The only thing now is that i need to create a working xorg.conf file. I might need some help with this if i can't work it out.

  6. #5
    Just Joined! GetToDaChopa's Avatar
    Join Date
    Nov 2009
    Posts
    4
    Ok having a problem with the xorg file.

    I'm getting the resolution that i want but the firefox window (in this case i'm also trying konqueror) does not fit the whole screen. It sits in the top left corner and then i have black space on the bottom right, if that makes sence. I've played around with the xorg file but no matter what resloution i am getting it always takes up 2/3rds of the screen.

    here is the xorg.conf file if anyone can spot anything. I think i have to get the horizontal sinc sorted?

    Code:
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "Device"
        Identifier  "VMware SVGA"
        Driver      "vmware"
    EndSection
    
    
    Section "Screen"
    	Identifier	"Default Screen"
        Device      "VMware SVGA"
        Monitor     "vmware"
        # Don't specify DefaultColorDepth unless you know what you're
        # doing. It will override the driver's preferences which can
        # cause the X server not to run if the host doesn't support the
        # depth.
        Subsection "Display"
            # VGA mode: better left untouched
            Depth       4
            Modes       "800x600"
            ViewPort    0 0
        EndSubsection
        Subsection "Display"
            Depth       8
            Modes       "800x600"
            ViewPort    0 0
        EndSubsection
        Subsection "Display"
            Depth       15
            Modes       "800x600"
            ViewPort    0 0
        EndSubsection
        Subsection "Display"
            Depth       16
            Modes       "1024x768"
            ViewPort    0 0
        EndSubsection
        Subsection "Display"
            Depth       24
            Modes       "1024x768"
            ViewPort    0 0
        EndSubsection
    EndSection
    Section "InputDevice"
      Driver "vmmouse"
      Identifier "VMware Mouse"
      Option "Buttons" "5"
      Option "Device" "/dev/input/mice"
      Option "Protocol" "IMPS/2"
      Option "ZAxisMapping" "4 5"
      Option "Emulate3Buttons" "true"
    EndSection
    Section "Monitor"
        Identifier      "vmware"
        VendorName      "VMware, Inc"
        HorizSync       1-10000
        VertRefresh     1-10000
    EndSection

  7. #6
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    I would wager a guess that the problem is firefox, not your xorg.conf.

    The firefox man page reports you can open it with a height and width option. But others report that doesn't actually work.

    You might have an easier time of it if you use a lightweight window manager like pekwm. It's an additional ~1MB on your system and, since it's what they do and all, it's much easier to tell the WM where and how to place windows. You can also have it start without any window decoration or borders or whatever, if you prefer.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •