Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
For some reason i manually installed gtk+-2.10.14! After the next restart it is showing the error as shown in the photos below. when i googled i saw to remove .ICEauthority ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! chinmaya_n's Avatar
    Join Date
    Jan 2009
    Posts
    8

    Smile Your session only lasted less than 10 seconds!!


    For some reason i manually installed gtk+-2.10.14!

    After the next restart it is showing the error as shown in the photos below.

    when i googled i saw to remove .ICEauthority in the home directory... i did! No beans!

    Any ideas!


    Edit1: I'm now running on a live cd! Better to tell to do from a live cd, rather than doing restart and going to terminal!
    I tried failsafe GNOME also .... no use

    Edit2: These is present in the .xsession-errors:
    Code:
    /etc/gdm/Xsession: Beginning session setup...
    Setting IM through im-switch for locale=en_IN.
    Start IM through /etc/X11/xinit/xinput.d/all_ALL linked to /etc/X11/xinit/xinput.d/default.
    I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
    I: caps.c: Dropping root privileges.
    I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
    N: main.c: Called SUID root and real-time and/or high-priority scheduling was requested in the configuration. However, we lack the necessary privileges:
    N: main.c: We are not in group 'pulse-rt', PolicyKit refuse to grant us the requested privileges and we have no increase RLIMIT_NICE/RLIMIT_RTPRIO resource limits.
    N: main.c: For enabling real-time/high-priority scheduling please acquire the appropriate PolicyKit privileges, or become a member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits for this user.
    Gtk-Message: Failed to load module "canberra-gtk-module": libcanberra-gtk-module.so: cannot open shared object file: No such file or directory
    Gtk-Message: Failed to load module "canberra-gtk-module": libcanberra-gtk-module.so: cannot open shared object file: No such file or directory
    Gtk-Message: Failed to load module "canberra-gtk-module": libcanberra-gtk-module.so: cannot open shared object file: No such file or directory
    gnome-session[4158]: WARNING: Could not parse desktop file /etc/xdg/autostart/update-notifier-kde.desktop: Key file does not have key 'Type'
    gnome-session[4158]: WARNING: could not read /etc/xdg/autostart/update-notifier-kde.desktop
    gnome-session[4158]: WARNING: Unable to find provider '' of required component 'panel'
    Gtk-Message: Failed to load module "canberra-gtk-module": libcanberra-gtk-module.so: cannot open shared object file: No such file or directory
    Gtk-Message: Failed to load module "canberra-gtk-module": libcanberra-gtk-module.so: cannot open shared object file: No such file or directory
    
    ** (gnome-settings-daemon:4245): WARNING **: /usr/lib/libgnome-desktop-2.so.11: undefined symbol: gdk_pixbuf_apply_embedded_orientation
    
    ** (gnome-settings-daemon:4245): WARNING **: Cannot load plugin 'XRandR' since file '/usr/lib/gnome-settings-daemon-2.0/libxrandr.so' cannot be read.
    
    ** (gnome-settings-daemon:4245): WARNING **: Error activating plugin 'XRandR'
    
    ** (gnome-settings-daemon:4245): WARNING **: /usr/lib/libgnome-desktop-2.so.11: undefined symbol: gdk_pixbuf_apply_embedded_orientation
    
    ** (gnome-settings-daemon:4245): WARNING **: Cannot load plugin 'X Settings' since file '/usr/lib/gnome-settings-daemon-2.0/libxsettings.so' cannot be read.
    
    ** (gnome-settings-daemon:4245): WARNING **: Error activating plugin 'X Settings'
    
    ** (gnome-settings-daemon:4245): WARNING **: /usr/lib/libgnome-desktop-2.so.11: undefined symbol: gdk_pixbuf_apply_embedded_orientation
    
    ** (gnome-settings-daemon:4245): WARNING **: Cannot load plugin 'Font' since file '/usr/lib/gnome-settings-daemon-2.0/libfont.so' cannot be read.
    
    ** (gnome-settings-daemon:4245): WARNING **: Error activating plugin 'Font'
    
    ** (gnome-settings-daemon:4245): WARNING **: /usr/lib/libgnome-desktop-2.so.11: undefined symbol: gdk_pixbuf_apply_embedded_orientation
    
    ** (gnome-settings-daemon:4245): WARNING **: Cannot load plugin 'Sound' since file '/usr/lib/gnome-settings-daemon-2.0/libsound.so' cannot be read.
    
    ** (gnome-settings-daemon:4245): WARNING **: Error activating plugin 'Sound'
    
    ** (gnome-settings-daemon:4245): WARNING **: /usr/lib/libgnome-desktop-2.so.11: undefined symbol: gdk_pixbuf_apply_embedded_orientation
    
    ** (gnome-settings-daemon:4245): WARNING **: Cannot load plugin 'Keyboard' since file '/usr/lib/gnome-settings-daemon-2.0/libkeyboard.so' cannot be read.
    
    ** (gnome-settings-daemon:4245): WARNING **: Error activating plugin 'Keyboard'
    
    ** (gnome-settings-daemon:4245): WARNING **: /usr/lib/libgnome-desktop-2.so.11: undefined symbol: gdk_pixbuf_apply_embedded_orientation
    
    ** (gnome-settings-daemon:4245): WARNING **: Cannot load plugin 'Mouse' since file '/usr/lib/gnome-settings-daemon-2.0/libmouse.so' cannot be read.
    
    ** (gnome-settings-daemon:4245): WARNING **: Error activating plugin 'Mouse'
    
    ** (gnome-settings-daemon:4245): WARNING **: /usr/lib/libgnome-desktop-2.so.11: undefined symbol: gdk_pixbuf_apply_embedded_orientation
    
    ** (gnome-settings-daemon:4245): WARNING **: Cannot load plugin 'Accessibility Keyboard' since file '/usr/lib/gnome-settings-daemon-2.0/liba11y-keyboard.so' cannot be read.
    
    ** (gnome-settings-daemon:4245): WARNING **: Error activating plugin 'Accessibility Keyboard'
    
    ** (gnome-settings-daemon:4245): WARNING **: /usr/lib/libgnome-desktop-2.so.11: undefined symbol: gdk_pixbuf_apply_embedded_orientation
    
    ** (gnome-settings-daemon:4245): WARNING **: Cannot load plugin 'Keybindings' since file '/usr/lib/gnome-settings-daemon-2.0/libkeybindings.so' cannot be read.
    
    ** (gnome-settings-daemon:4245): WARNING **: Error activating plugin 'Keybindings'
    
    ** (gnome-settings-daemon:4245): WARNING **: /usr/lib/libgnome-desktop-2.so.11: undefined symbol: gdk_pixbuf_apply_embedded_orientation
    
    ** (gnome-settings-daemon:4245): WARNING **: Cannot load plugin 'Background' since file '/usr/lib/gnome-settings-daemon-2.0/libbackground.so' cannot be read.
    
    ** (gnome-settings-daemon:4245): WARNING **: Error activating plugin 'Background'
    
    ** (gnome-settings-daemon:4245): WARNING **: /usr/lib/libgnome-desktop-2.so.11: undefined symbol: gdk_pixbuf_apply_embedded_orientation
    
    ** (gnome-settings-daemon:4245): WARNING **: Cannot load plugin 'Media keys' since file '/usr/lib/gnome-settings-daemon-2.0/libmedia-keys.so' cannot be read.
    
    ** (gnome-settings-daemon:4245): WARNING **: Error activating plugin 'Media keys'
    
    ** (gnome-settings-daemon:4245): WARNING **: /usr/lib/libgnome-desktop-2.so.11: undefined symbol: gdk_pixbuf_apply_embedded_orientation
    
    ** (gnome-settings-daemon:4245): WARNING **: Cannot load plugin 'Clipboard' since file '/usr/lib/gnome-settings-daemon-2.0/libclipboard.so' cannot be read.
    
    ** (gnome-settings-daemon:4245): WARNING **: Error activating plugin 'Clipboard'
    
    ** (gnome-settings-daemon:4245): WARNING **: /usr/lib/libgnome-desktop-2.so.11: undefined symbol: gdk_pixbuf_apply_embedded_orientation
    
    ** (gnome-settings-daemon:4245): WARNING **: Cannot load plugin 'Screensaver' since file '/usr/lib/gnome-settings-daemon-2.0/libscreensaver.so' cannot be read.
    
    ** (gnome-settings-daemon:4245): WARNING **: Error activating plugin 'Screensaver'
    
    ** (gnome-settings-daemon:4245): WARNING **: /usr/lib/libgnome-desktop-2.so.11: undefined symbol: gdk_pixbuf_apply_embedded_orientation
    
    ** (gnome-settings-daemon:4245): WARNING **: Cannot load plugin 'Typing Break' since file '/usr/lib/gnome-settings-daemon-2.0/libtyping-break.so' cannot be read.
    
    ** (gnome-settings-daemon:4245): WARNING **: Error activating plugin 'Typing Break'
    
    ** (gnome-settings-daemon:4245): WARNING **: /usr/lib/libgnome-desktop-2.so.11: undefined symbol: gdk_pixbuf_apply_embedded_orientation
    
    ** (gnome-settings-daemon:4245): WARNING **: Cannot load plugin 'Housekeeping' since file '/usr/lib/gnome-settings-daemon-2.0/libhousekeeping.so' cannot be read.
    
    ** (gnome-settings-daemon:4245): WARNING **: Error activating plugin 'Housekeeping'
    /usr/bin/gnome-session: symbol lookup error: /usr/bin/gnome-session: undefined symbol: gdk_x11_display_broadcast_startup_message

  2. #2
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    I'm not sure which distro/version you are using, but you can't just install libraries for GTK on a gnome desktop manually without updating every other library. As you can see, you caused your system to break.

  3. #3
    Just Joined! chinmaya_n's Avatar
    Join Date
    Jan 2009
    Posts
    8

    Smile

    Quote Originally Posted by coopstah13 View Post
    I'm not sure which distro/version you are using, but you can't just install libraries for GTK on a gnome desktop manually without updating every other library. As you can see, you caused your system to break.
    I'm using UBUNTU !
    So what do you want me to do now !!
    Make a fresh install !?
    Is there any other ways to upgrade other libraries ??

  4. #4
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    It really doesn't make sense to perform such an overhaul on a system like that. For a distro like ubuntu, the libraries will never be the latest. If you want the latest you should use a rolling release distro like arch, or if you prefer debian-based, then use debian unstable.

    You should probably reinstall, unless you can manage to uninstall everything else you installed.

  5. #5
    Just Joined! chinmaya_n's Avatar
    Join Date
    Jan 2009
    Posts
    8

    Smile

    Thanks for the help....! coopstah13

    I'll plan a fresh install in 2 days b'se first I need to backup my files from my home!
    (such a huge process! )

    Once again thanku!

  6. #6
    Just Joined! chinmaya_n's Avatar
    Join Date
    Jan 2009
    Posts
    8
    Hey folks ........ I've got an idea...
    Any way i'm using Jaunty now.... If i upgrade to Karmic through command line will this get solved ??

    sudo apt-get dist-upgrade

    I dont mind time! It may take nearly 7-8 hours. I'll stop the process at anytime and start again if anyproblem occurs....!
    What will you say ??

  7. #7
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Posts
    3,847
    Take what I say with a grain of salt. Before I experiment. I google a bit first. Then I decide if it may be fun to try. Then like any experiment. I dive into it. Sometimes I am the Windsheild. Sometimes I am the bug.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  8. #8
    Just Joined! chinmaya_n's Avatar
    Join Date
    Jan 2009
    Posts
    8
    rokytnji,

    I didnt get u !

  9. #9
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Posts
    3,847
    I didnt get u
    Sorry. Being a Southern Boy I forget that my terms may fly over certain persons heads.

    I google= I look for other peoples experiences that have tried what I am about to try to do.

    Sometimes I am the Windshield= Success with my experiment
    Sometimes the Bug= Failure with my Experiment. Broke My install. Time for a reinstall.

    Grain of Salt= Means you don't have to accept what I say as gospel.
    Gospel= As the only way to go about doing things.

    Hope that clears it up for you.

    As a side note. With Ubuntu I only do clean installs. I stay away from the Upgrade Distro.

    I run AntiX also which has the Ditribution Upgrade option Via aptitude and apt-get. Risky at best. One needs to pay attention to what gets deleted,and Upgraded, and added. Lots of info to process. Easy way to lose applications and sometimes failure to boot because of Kernel Upgrades. Like from kernel 2.6.27 to 2.6.31.5. What works for one user may not work for another user because hardware specs are so varied. Only Experimenting will let you know for sure.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  10. #10
    Just Joined! chinmaya_n's Avatar
    Join Date
    Jan 2009
    Posts
    8
    Thanx man !!

    I'll try !!

    Thanks for everyone !!

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •