Find the answer to your Linux question:
Results 1 to 3 of 3
i need to legitimately use this because X crashes every so often, oftentimes at login. i tried adding Options "DontZap" "false" to xorg.conf but i stall can't use ctrl alt ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2009
    Posts
    11

    Angry Xorg problem --- How do i reenable ' ctrl alt backspace ' in Xorg?


    i need to legitimately use this because X crashes every so often, oftentimes at login.

    i tried adding Options "DontZap" "false" to xorg.conf but i stall can't use ctrl alt backspace.

  2. #2
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    What distribution are you running?

    DontZap has also been deprecated now.

    Couple of options that might work.

    Set this to run when you start your window manager/desktop environment.
    Code:
    setxkbmap -option terminate:ctrl_alt_bksp
    Or create a HAL policy. (This will be deprecated soon, since HAL is going away. Ubuntu 10.04 has already ditched it.) Borrowed from the Arch Wiki:
    Add the following to /etc/hal/fdi/policy/10-keymap.fdi to enable this behavior. If that file does not exist, copy it from the template at /usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi:

    Code:
    # cp /usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi /etc/hal/fdi/policy/10-keymap.fdi
    Check for a line resembling this:
    Code:
    <merge key="input.xkb.options" type="string">terminate:ctrl_alt_bksp</merge>
    If the input.xkb.options line already exists, add terminate:ctrl_alt_bksp to the existing line:
    Code:
    <merge key="input.xkb.options" type="string">grp:alt_shift_toggle,terminate:ctrl_alt_bksp</merge>
    Afterwards, Restart HAL and Xorg.

  3. #3
    Just Joined!
    Join Date
    Feb 2007
    Posts
    7
    I had same problem a while ago. It turned out to be the Gnome keyboard indicators fault. Right click on it, Keyboard preferences, Layouts, Layout options, in the middle - Key sequence to kill the X server. Probably some other key combinations in that menu are preventing the ctrl or alt being understood the way it is necessary.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •