Find the answer to your Linux question:
Results 1 to 5 of 5
Until now I've used my motherboard's integrated video card (ATI HD3300), with a desktop monitor and a television connected to it. The TV was connected via an HDMI cable. With ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2010
    Posts
    3

    Nvidia HDMI with strange colors


    Until now I've used my motherboard's integrated video card (ATI HD3300), with a desktop monitor and a television connected to it. The TV was connected via an HDMI cable. With the catalyst driver I could set up my TV to display 720p and 1080p signals correctly.
    Last week I've purchased an Nvidia video card. I've installed it, downloaded the nvidia driver, and configured it.
    Unfortunately with the Nvidia Control Panel I can't set up my TV correctly: I have 1920×1080 resolution, but the colors are very strange.
    I've made a photo of it to show what I mean.

    Any help would be appreciated.

    Thanx in advance!
    Attached Images Attached Images

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,596
    1. What is your operating system (distribution+version)?
    2. What nVidia board did you get (nVidia chip set, such as 8800GT) and which board vendor/manufacture?
    3. Which nVidia driver did you download? and was it one of the system packages, or did you get it directly from nVidia?
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Just Joined!
    Join Date
    Feb 2010
    Posts
    3
    The operating system is Kubuntu 9.10.
    The board is Gigabyte 9800GT.

    I've tried the driver from the Nvidia homepage (190.53) and the one from the reposítory (185.18.36), but with the same result.

  4. #4
    Just Joined!
    Join Date
    Feb 2010
    Posts
    3
    Problem solved...

    I had to change the refresh rate to 1920×1080@24fps, and insert the line
    Option "UseEDIDFreqs" "False"
    to the xorg.conf file.

  5. #5
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,596
    Happy to hear you sorted that out. Depending upon the TV/monitor the device might not report the correct specs regarding frequency and refresh rates to the driver, resulting in the need to manually update the xorg.conf file as you did.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •