Find the answer to your Linux question:
Results 1 to 4 of 4
Hi. I just did a fresh install of Debian GNU/Linux a computer with an ASUS EAH4350 (ATI Radeon HD 4350 chip) graphics card and the graphics didn't come up -- ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2010
    Posts
    8

    [SOLVED] Graphics won't work on fresh Debian install - over range


    Hi.

    I just did a fresh install of Debian GNU/Linux a computer with an ASUS EAH4350 (ATI Radeon HD 4350 chip) graphics card and the graphics didn't come up -- the monitor said "over range". I can't get you the /var/log/Xorg.0.log as it's too long for one but it mentioned something about using "shadow framebuffer", etc. could that be the problem? Also, the X config file appears to be skeletal. If I generate a new X config file with "X -configure", I get a more filled-out looking config file but it still doesn't work (same monitor problem), and in that config the driver is set to "vesa" and it's listed as "Unknown Card". What's going on here? Is this card unsupported by Debian? Do I need a newer Debian release? (I think this one was like 1 year old or something.) I tried adding settings to reduce refresh rate, etc. but that didn't help either.

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Try this Generic Configuration and install ATI Proprietary driver after fixing Graphics Problem.
    Code:
    Section "Device"
    	Identifier	"Configured Video Device"
    	Driver		"vesa"
    EndSection
    
    Section "Monitor"
    	Identifier	"Generic Monitor"
    	Option		"DPMS"
    	HorizSync	30-71
    	VertRefresh	50-160
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Device		"Configured Video Device"
    	Monitor		"Generic Monitor"
    	DefaultDepth	24
    	SubSection "Display"
    		Depth		24
    		Modes		"1280x1024" "1024x768" 
    	EndSubSection
    EndSection
    
    Section "ServerLayout"
    	Identifier	"Default Layout"
    	Screen		"Default Screen"
    	InputDevice	"Generic Keyboard"
    	InputDevice	"Generic Mouse"
    EndSection
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Feb 2010
    Posts
    8
    Hmm. It seems just adding the subsection about "Display" specifying modes resolved the problem. I didn't need the rest... Maybe it was just setting the resolution too high for any of the monitors I had (1920x1440 was the highest that appeared in the Xorg.0.log and none of the monitors I have go up that high.).

  4. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Refresh Rates also play an important role in Display settings Correct Refresh Rates enable higher resolution.
    Anyways, if Display resolution sorted out your problem, no need to play with xorg.conf unless its necessary.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •