Find the answer to your Linux question:
Results 1 to 10 of 10
How can I stop the mouse wheel from switching desktops? this is infuriating! i've had to disable multiple desktops. I cant find any options anywhere for this. pls help, thanks, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2007
    Posts
    24

    KDE Stop mouse wheel from switching desktops


    How can I stop the mouse wheel from switching desktops? this is infuriating! i've had to disable multiple desktops. I cant find any options anywhere for this.

    pls help,


    thanks,

    strax

  2. #2
    Linux Newbie theNbomr's Avatar
    Join Date
    May 2007
    Location
    BC Canada
    Posts
    155
    There is a setting in the virtual desktop pager for this. I only have KDE 3.x available right now, but if you right-click on the pager (the widget in the 'panel' that shows the Desktop thumbnails), and select the 'Configure...' menu, it will bring up a dialog with a checkbox to enable/disable the feature.
    --- rod.
    Stuff happens. Then stays happened.

  3. #3
    Just Joined!
    Join Date
    Feb 2007
    Posts
    24
    thanks for the info. kde 4.35 here and there is no option on pager configure desktop. its a shame really. I'm just going to switch to gnome.


    thanks,

    strax

  4. $spacer_open
    $spacer_close
  5. #4
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Quote Originally Posted by strax View Post
    thanks for the info. kde 4.35 here and there is no option on pager configure desktop. its a shame really. I'm just going to switch to gnome.
    I'm in KDE 4.4.2 at the moment and it appears that there is no working option to disable the mouse wheel from switching desktops. Perhaps I'm wrong, but I could have sworn that it could be disabled in an earlier version of KDE4.
    oz

  6. #5
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Okay, I wasn't ready to give up just yet so kept looking and finally found it!

    right-click on the desktop and choose Desktop Activity Settings

    ...then choose Mouse Actions

    ...and then on the dropdown bar where it says Switch Desktop (right next to Vertical-Scroll), choose the option that you want the mouse scroll wheel to do.

    Click OK
    oz

  7. #6
    Just Joined!
    Join Date
    Feb 2007
    Posts
    24
    thanks for not giving up.

    unfortunetly, i dont have any option for mouse actions in desktop settings.

  8. #7
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    They keep changing up the way things are done in KDE4 so your version might be different from my own and work differently. What release of KDE4 are you running?

    Hopefully someone running the same release as you will reply with something that will work for you.

    In the interim, I'll check it again on my own system once I'm able to get back to that machine, but it might be a few days.
    oz

  9. #8
    Just Joined!
    Join Date
    Feb 2007
    Posts
    24
    Thanks for your help. I was running kde 4.35. I installed kde 4.4. There is now an option for mouse actions and i am able to stop the unwanted scrolling!! its like getting rid of a psycho stalker. i did have to disable it on each desktop, so be aware of that if you have the same problem.

    best,

    strax

  10. #9
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Quote Originally Posted by strax View Post
    Thanks for your help. I was running kde 4.35. I installed kde 4.4. There is now an option for mouse actions and i am able to stop the unwanted scrolling!! its like getting rid of a psycho stalker.
    I'm running 4.4 as well. Glad you were able to stop the stalker!
    oz

  11. #10
    Just Joined!
    Join Date
    Feb 2005
    Posts
    14
    Bitten once again. OpenSuSE has not pushed 4.4 so I am SOL and have to live with this brain damage. The KDE folks claim they research features for usefulness, but I really doubt it. This is not the first time for this sort of problem. Not even the second. It happens too often.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •