not sure if it's the same problem, but the solution may be similar. When I started using Fedora Core 3, the thing would shut down in a very strange manner for no reason, fixed the problem by setting the BIOS setting for system performance from "Optimal" to "Turbo". A strange problem with a strange solution. I doubt that's your problem, but you might try the solution.