Find the answer to your Linux question:
Results 1 to 7 of 7
The system is a Sun Ultra 5, 384MB RAM, 40GB HD, 270MHz UltraSPARC. The first time I installed Debian, I chose to install the desktop environment. Everything went perfectly smoothly ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2010
    Posts
    66

    GUI not starting, Debian on Sun Ultra5


    The system is a Sun Ultra 5, 384MB RAM, 40GB HD, 270MHz UltraSPARC.

    The first time I installed Debian, I chose to install the desktop environment. Everything went perfectly smoothly from the net install, and then when it finished, the computer was rebooted. Upon reboot, Linux loaded normally, but once it tried to start the GUI, the screen went black, and I could not login.

    So, I re-installed without the desktop environment option, which left out the GUI. I decided that I want to try out Xfce. So yesterday I;

    #aptitude install xorg
    #aptitude install xfce4
    #update rc.d -f xfce remove
    apt-get install rcconf

    I unchecked X11 in rcconf. I also modified my xorg.conf file so there was a SubSection for a single resolution. Anyway, when I type startx, the screen goes black, just like it did before. I do notice that in the upper left there appears to be a white dash or underscore, but other than that, its black.

    So any advice on how to get a GUI working is appreciated.

    -Chris P

  2. #2
    Linux Newbie
    Join Date
    Aug 2006
    Posts
    124

    Problem on Ultra5

    Hi.

    I had the same problem with Ultra5 and Blade100.
    At first, the reference clock is not the same frequency as on the standard PCs. Pick a look in dmesg, on the Blade100 it was 29.5 MHz instead of 14.31818 like on standard PCs. So you may add a "option "reference_clock" "29.5MHz" " in your xorg.conf. I can't check the exact syntax for my Blade100 is dead, and I don't have acces to the Ultra5 anymore.
    I picked up a second problem, with Gentoo and with Debian too. I wasn't able to get a GUI with the last versions of xorg. The last working version I tried was Debian4. Maybe you should install and make it run, then upgrade to Debian5.
    If you have a PCI slot in your Sun, maybe you can plug a standard PCI VGA and make use of it, instead of the weirdly clocked ATI Mach64 onboard.

  3. #3
    Just Joined!
    Join Date
    Apr 2010
    Posts
    66
    Well, after getting a SCSI CD-ROM working on the Ultra2, and then getting a Compaq 9.1GB 10k rpm SCA drive working with it, I then focused my efforts onto the Ultra2 instead of the Ultra5. The Ultra2 worked immediately with the TurboXGX card it had in it. Unfortunately that card has 1MB VRAM, and only supports 256 colors. Well, I went ahead and purchased a Creator3D card for it, as that has a whopping 16MB VRAM! And that card works until Linux tries to load the GUI : ) So, I think I will have to try this reference clock idea. I cant try right now, but does anybody know the exact syntax for this? Im thinking:

    SubSection
    reference_clock "29.5"
    EndSubSection

    Or maybe that should go in the same subsection as something else, such as the resolution?

    Thanks

    -Chris P

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Apr 2010
    Posts
    66
    So just to share the specs on the new system. It is a Sun Ultra2, Dual 200MHz SPARC I CPUs, 512MB RAM, 9.1GB 10k rpm SCA SCSI drive, 50pin SCSI CDROM, and Debian was installed via the netinstall CD, kernel installed (IIRC) was 2.6.26 smp.

    The GUI had no problem loading on the Sbus VGA card I picked the system up with, but the GUI will not load with the UPA Creator3D card installed. However, the card did output in thousands (or millions) of colors before the GUI tried to activate. Im going to try removing the Sbus card but somehow I doubt that will solve the issue.

  6. #5
    Linux Newbie
    Join Date
    Aug 2006
    Posts
    124

    X on sun issue

    Hi Coblat60.

    Unfortunately, the only Ultra2 I saw were on a departure to the destruction. Tens of them. It was at France Telecom. No way to buy one. No way to power one one last time...
    I don't know what chipset is on the Creator3D. However, you may find the documentation for ATI chipset on 3 double U dot X dot org slash archive slash X11R6.8.0 slash doc slash ati5 dot html ; that's where I found the issue for the ATI on the Blade100. I'm not allowed to post URLs here

    Sorry if I can't help you more

    Alain

  7. #6
    Just Joined!
    Join Date
    Apr 2010
    Posts
    66
    So, I re-installed Debian, and left out the Desktop from the install. I installed xorg, xfce4, and rcconf. I used rcconf to keep the GUI from loading so as to not let problems with X keep me from logging in. I edited xorg.conf with a reference clock option of 29.5 MHz.

    Now it seems I have a driver issue. Basically I think that maybe the drivers are not installed. Any ideas? The card is the Creator3D, which I believe would use the FFB driver.

  8. #7
    Just Joined!
    Join Date
    Apr 2010
    Posts
    66
    OK I got the GUI working by modifying the xorg.conf file. Under device, driver, were 2 drivers, one for each card. I deleted the line for the driver of the original card. Saved and typed startx. Success.

    Since I changed the subject of this post to an Ultra2, I dont think my original topic is technically solved. Ive just been ignoring the Ultra5 since I got the Ultra2 to properly recognize the SCSI drives.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •