Find the answer to your Linux question:
Results 1 to 9 of 9
Hi, I'm building a new distribution that runs off a live cd. Now I'm trying to get the gui to work. I'm using the XFree86 4.8.0 binaries with Linux 2.6.35.1. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2010
    Location
    England
    Posts
    28

    XFree86: xterm won't start


    Hi,

    I'm building a new distribution that runs off a live cd. Now I'm trying to get the gui to work. I'm using the XFree86 4.8.0 binaries with Linux 2.6.35.1.

    The problem:
    When I type startx I see the default X screen for a couple of seconds then it goes back to the terminal and says:
    Code:
    xterm: Error 32, errno 0: Success
    Reason: get_pty: not enough ptys
    I have checked my kernel config and Legacy PTYS is enabled. How can I fix this problem?

    James

  2. #2
    Just Joined!
    Join Date
    Aug 2010
    Posts
    4

    xterm and ptys

    More likely than not, the xterm binary would be using Unix98 ptys.
    Legacy ptys are the explicit pairs of ttyp/ptyp in /dev.

  3. #3
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,664
    You will be better off running the Xorg servers now, instead of the XFree86 ones.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Aug 2010
    Location
    England
    Posts
    28
    Hi,

    I'm using XFree86 as it seems smaller and they provide binaries. The xorg build process seemed really confusing. Also, I have unix ptys support enabled also.

    James

  6. #5
    Just Joined!
    Join Date
    Aug 2010
    Location
    England
    Posts
    28
    What should be in the /dev directory that would tell me that ptys are working? I have /dev/ptmx.

  7. #6
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,664
    You should also have a directory like /dev/pts with a number of device entries in it.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  8. #7
    Just Joined!
    Join Date
    Aug 2010
    Location
    England
    Posts
    28
    I see... Unfortunatly I dont have that . How can this be created? Do I need to use mknod and if so what devices do I need to create?

  9. #8
    Just Joined!
    Join Date
    Aug 2010
    Location
    England
    Posts
    28
    Ok, so I created a directory in /dev/pts. But what device files do I need to create inside?

  10. #9
    Just Joined!
    Join Date
    Aug 2010
    Location
    England
    Posts
    28
    Sorry for the triple post but I can't find the edit button.

    I have run these commands:
    Code:
    mknod /dev/pts/0 c 136 0
     mknod /dev/pts/1 c 136 1
     mknod /dev/pts/2 c 136 2
     mknod /dev/pts/3 c 136 3
     mknod /dev/pts/4 c 136 4
     mknod /dev/pts/5 c 136 5
     mknod /dev/pts/6 c 136 6
     mknod /dev/pts/7 c 136 7
     mknod /dev/pts/8 c 136 8
    But this did not improve the situation. I still get:
    Code:
    xterm: Error 32: errno 0: Success
    Reason: get_pty: not enough ptys
    login: Error 32: errno 0: Success
    Reason: get_pty: not enough ptys

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •