Find the answer to your Linux question:
Results 1 to 8 of 8
I should mention that this has happened to me with two different distributions. One was Debian, which i uninstalled, and the other is Slackware, which is currently installed. Both are ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2010
    Posts
    4

    Startx leads to no gui


    I should mention that this has happened to me with two different distributions. One was Debian, which i uninstalled, and the other is Slackware, which is currently installed. Both are the most recent versions, if i recall, 5.05 and 13.1. Whenever i would type startx, on Debian my monitor would black out and tell me that its out of range. On Slackware, my monitor stays lit, but black, and tells me nothing. I'm fairly certain that its the same problem affecting both distributions. If i had to guess, i would say its a driver issue, since when i run the OS's virtually inside windows, there aren't any video/x server issues to speak of. My graphics 'card' is an integrated intel HD graphics card that came with the i5. Another caveat to mention is i do not have internet currently working for the linux install. I figure i would tackle the x server first, then go after wireless. Any help is appreciated, and I will gladly provide more information as needed. Thank you.

  2. #2
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Hello and welcome to the forums!

    For Debian and Slackware you need to install the Xserver in order to have a GUI, but assuming you've done that "out of range" error messages usually mean that your vertical refresh / horizontal sync rates are not adjusted properly. You can check the manual for your monitor to set them correctly in the /etc/X11/xorg.conf file then try startx again. Keep in mind that you need root permissions to edit that file. If you don't have that file, you can create it manually, or there are several different scripts that can create it for you.

    If you haven't already done so, I'd advise reading the Debian Installation Manual and Slackware Essentials for some tips on working with each distro.

    For the wireless issue, you can start here:

    http://www.linuxforums.org/forum/wir...tart-here.html
    oz

  3. #3
    Just Joined!
    Join Date
    Aug 2010
    Posts
    4
    All right.
    I have continued my tradition of..no success. The X server is installed, and ive been looking at setting the vertical refresh and horizontal sync rates. looking at the manual for my monitor, an asus ve205, it lists a variety of refresh and sync rates, depending on the resolution. how can i figure out what resolution slackware/kde is going to load, so i can set the refresh and sync rates appropriately? I tried setting them to several different values manually after perusing the man pages for xorg.conf but i had no luck.
    Also i was rereading the slackware essentials and it mentions two scripts to create the xorg.conf file. one is xorgsetup, which i do have, but doesnt set up a working x server. it continues to give me a black screen when i startx. the other the essentials mentions is xorgconfig, which i dont have. where can i get that, since xorgconfig allows me to choose the sync/refresh rates, and it will set them up, which could eliminate any user error on my part, which is probable..

  4. $spacer_open
    $spacer_close
  5. #4
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    As ozar mentioned, sounds like it is definitely a monitor issue. Try running as root:
    Code:
    xorgconfig
    There will be a long list of questions it will ask so take your time. After you input the right values, it will create an xorg.conf for you. After this process, try startx again. If no joy, you will at least have an xorg.conf file in /etc/X11 to work with.

    If you are a new Linux user, both of the distros you mention are fairly challenging for new users and have to be configured "by hand," unlike other more new user friendly distros such as SuSE and Ubuntu that have fancy utilities that do much of this work for you.

    Setting up the X window system with xorgconfig in Slackware.

    Good luck!
    Last edited by Dapper Dan; 08-27-2010 at 09:20 PM.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  6. #5
    Just Joined!
    Join Date
    Aug 2010
    Posts
    4
    Hi there.

    I still dont have the xorgconfig command for some reason. It says the command isnt found whenever i run it as root. Also, is there a key combination in Slackware that will allow me to kill the x server so i can get back into the terminal to edit xorg.conf without having to hold down the power button and force a restart? In Debian, the combination was ctrl+alt+f1. This doesnt work in slackware.

    As to the distro being challenging, thats part of why i chose it. It will force me to learn more about Linux and how it works. If i use Ubuntu or PCLinuxOS, like i have before, i can happily point and click through guis, and have the distro do everything for me, which doesnt help me learn it at all. Thats why I chose a more challenging distribution.

    Thanks everyone for all the help.

  7. #6
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    It's been a while since I used Slackware so you might need to include the full path. Try:
    Code:
    /usr/X11R6/bin/xorgconfig
    You'll need to do this as su. If that's not the path:
    Code:
    locate xorgconfig
    Quote Originally Posted by Salted View Post
    As to the distro being challenging, thats part of why i chose it. It will force me to learn more about Linux and how it works. If i use Ubuntu or PCLinuxOS, like i have before, i can happily point and click through guis, and have the distro do everything for me, which doesnt help me learn it at all. Thats why I chose a more challenging distribution.
    Thanks everyone for all the help.
    Glad to hear you are wanting to hone your command line skills and learn about configuring Linux. Slackware is a good choice!
    Linux Mint + IceWM Registered: #371367 New Members: click here

  8. #7
    Just Joined!
    Join Date
    Aug 2010
    Posts
    4
    All right. Sorry for the delay, but ive finally figured something out.

    Throughout the past week, i had been installing various distributions for my desktop, which has been having all of these X issues, as well as getting my laptop set up and configured first in Slackware, then in Ubuntu. Laptop works lovely, as of yet.

    As for my desktop, i still had been getting no GUI when trying startx, no matter what distribution i tried. i looked into my xorg log, and saw something along the lines of
    (EE) intel(0): No kernel modesetting driver detected.
    (II) UnloadModule: "intel"
    (EE) Screen(s) found, but none have a usable configuration.

    Fatal server error:
    no screens found
    So I started searching about that and read stuff about setting KMS up and trying lilo without setting any modes, as well as setting i915.modeset=1 as the mode, all of which failed miserably.

    Finally, around 30 seconds ago, I went into my bios, where i had previously changed my graphics memory from the default 32mb to 256mb to see how it would affect performance, if at all, in Windows. On a whim, I changed this back to the default 32mb and booted up Slackware. Startx loaded just fine, and I have a GUI. Oddly though, the screen is very 'shaky' and it looks like all of the pixels are vibrating, which is really giving me a headache to look at.

    My remaining questions are:
    A) Why did changing the graphics card memory in bios affect whether or not X worked?

    B) How can I fix the 'jittery'ness of my monitor?

    Thanks all

    PS: It feels good to have finally written a post that seems halfway informative.

  9. #8
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Look in /etc/X11/xorg.conf and find what module is listed. Here's mine as a reference and where to look:
    Code:
    Section "Device"
    
        #VideoRam    131072
        # Insert Clocks lines here if appropriate
        Identifier     "Nvidia 7300 LE"
        Driver         "nvidia"
    EndSection
    Try this... In those quotes for Driver, input "vesa":
    Code:
    Driver "vesa"
    Save, exit, log out and restart X and see what you get.
    Linux Mint + IceWM Registered: #371367 New Members: click here

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •