Find the answer to your Linux question:
Results 1 to 3 of 3
I'm having a problem with application windows 'stuttering' when dragging them across the screen, they do not move as smoothly as they should after a new O/S installation. I'm running ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2010
    Posts
    2

    'Juddery' application windows after a new linux installation


    I'm having a problem with application windows 'stuttering' when dragging them across the screen, they do not move as smoothly as they should after a new O/S installation.

    I'm running the latest kernel 2.6.9-89.0.29.ELsmp on RHEL4, Update 8. My monitor is a 22" Iiyama ProLite B2206WS monitor and Radeon HD 4350 graphics card.

    I've downloaded and installed the latest linux drivers (fglrx 6.8.0-8.771-1) from the ATI website. I removed the default xorg.conf file and run aticonfig --initial. I also tried both the DVI and D-SUB connections, but the 'juddering' problem still remains.

    I've tried setting the V and H sync rates manually using aticonfig, and some other changes in the xorg.conf file but that just causes a kernel panic on reboot!

    This is the default xorg.conf file generated by aticonfig:

    Section "ServerLayout"
    Identifier "aticonfig Layout"
    Screen 0 "aticonfig-Screen[0]-0" 0 0
    EndSection

    Section "Module"
    EndSection

    Section "Monitor"
    Identifier "aticonfig-Monitor[0]-0"
    Option "VendorName" "ATI Proprietary Driver"
    Option "ModelName" "Generic Autodetecting Monitor"
    Option "DPMS" "true"
    EndSection

    Section "Device"
    Identifier "aticonfig-Device[0]-0"
    Driver "fglrx"
    BusID "PCI:1:0:0"
    EndSection

    Section "Screen"
    Identifier "aticonfig-Screen[0]-0"
    Device "aticonfig-Device[0]-0"
    Monitor "aticonfig-Monitor[0]-0"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    EndSubSection
    EndSection

    I'd appreciate any advice!

    Ian

  2. #2
    Linux Engineer Segfault's Avatar
    Join Date
    Jun 2008
    Location
    Acadiana
    Posts
    877
    2.6.9 kernel is very old compared to your ATI card. There are certain options that have to be enabled in kernel to support this kind of card, and DRI support has to be turned off because this functionality is provided by ATI driver. Also, there are supporting Xorg libraries that probably are too old for this driver. Xorg server itself has to be at least 1.7, I think.

  3. #3
    Just Joined!
    Join Date
    Apr 2010
    Posts
    2
    Problem solved. Instead of selecting:

    Generate Distribution Specific Driver Package (i.e. an RPM)

    I selected 'Install driver 8.771 on X Org 6.8.x' and all worked great after a reboot.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •