Find the answer to your Linux question:
Results 1 to 3 of 3
with this .fonts.conf Code: <?xml version="1.0"?> <!DOCTYPE fontconfig SYSTEM "fonts.dtd"> <!-- /etc/fonts/local.conf file to configure system font access --> <fontconfig> <!-- Use the Autohinter --> <match target="font"> <edit name="autohint" mode="assign"><bool>true</bool></edit> ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2010
    Posts
    2

    Smile Fonts in firefox


    with this .fonts.conf
    Code:
    <?xml version="1.0"?>
    <!DOCTYPE fontconfig SYSTEM "fonts.dtd">
    <!-- /etc/fonts/local.conf file to configure system font access -->
    <fontconfig>
    
    <!-- Use the Autohinter -->
            <match target="font">
                    <edit name="autohint" mode="assign"><bool>true</bool></edit>
            </match>
    
    <!-- Disable Autohinting for bold fonts -->
            <match target="font">
                    <test name="weight" compare="more"><const>medium</const></test>
                    <edit name="autohint" mode="assign"><bool>false</bool></edit>
            </match>
    
    <!-- Enable sub-pixel rendering -->
    <!-- Uncomment this if you have an LCD screen -->
            <match target="font">
                    <edit name="rgba" mode="assign"><const>rgb</const></edit>
            </match>
    
    
    <!-- Exclude/Include a range of fonts for Anti Aliasing -->
    <!--
            <match target="font">
                    <test qual="any" name="size" compare="more"><double>9</double></test>
                    <test qual="any" name="size" compare="less"><double>20</double></test>
                    <edit name="antialias" mode="assign"><bool>true</bool></edit>
            </match>
    -->
    <!-- And/Or disable Anti Aliasing for a range on pixel-based size.
         Disabling this using both methods seems to fix Firefox. -->
    
            <match target="font">
                    <test compare="less" name="pixelsize" qual="any"><double>30</double></test>
                    <edit mode="assign" name="antialias"><bool>false</bool></edit>
            </match>
    
    
    <!-- Ignore any embedded bitmaps in TTF, etc (Microsoft's Calibri and others from Office 07/Vista have these) -->
            <match target="font" >
              <edit name="embeddedbitmap" mode="assign" >
                <bool>false</bool>
              </edit>
            </match>
    
    
    <!-- Other config options that were added to previous versions of config files in the Gentoo Wiki HOWTO.
         Need clarification. -->
    <!--
            <match target="font">
                    <edit name="hinting" mode="assign"><bool>true</bool></edit>
                    <edit name="hintstyle" mode="assign"><const>hintmedium</const></edit>
            </match>
    
    -->
    
    </fontconfig>
    i have this sort of fonts in my Firefox

    (fflinux.png in attachments)

    Is it possible to change my .fonts.conf so that this fonts look like this

    (ffwindows.png in attachments)

    p.s. i don't want antialiasing
    p.s.s. thank you in advance
    Attached Images Attached Images

  2. #2
    Just Joined!
    Join Date
    Oct 2010
    Posts
    2
    sorry forum over optimized my images, this are originals
    img29.imageshack.us/img29/4951/fflinux.png
    img29.imageshack.us/img29/4951/fflinux.png

  3. #3
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Hello and Welcome to the forums
    Check out this link for a little info on Debian fonts, which should work on most any distro.
    http://www.linuxforums.org/forum/deb...ts-debian.html
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •