Find the answer to your Linux question:
Results 1 to 2 of 2
On startx, I get the error: failed to open /dev/io for extended IO Does anyone know how I can fix this? More specifically: XFree86 Version 4.2.1 / X Window System ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2003
    Posts
    3

    X fails to open /dev/io....


    On startx, I get the error:

    failed to open /dev/io for extended IO

    Does anyone know how I can fix this?

    More specifically:

    XFree86 Version 4.2.1 / X Window System
    (protocol Version 11, revision 0, vendor release 6600)
    Release Date: 3 September 2002
    If the server is older than 6-12 months, or if your card is
    newer than the above date, look for a newer version before
    reporting problems. (See http://www.XFree86.Org/)
    Build Operating System: FreeBSD 5.0-RC i386 [ELF]
    Module Loader present
    Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/XFree86.0.log", Time: Mon May 26 15:28:54 2003
    (==) Using config file: "/etc/X11/XF86Config"
    (==) ServerLayout "Simple Layout"
    (**) |-->Screen "Screen 1" (0)
    (**) | |-->Monitor "My Monitor"
    (**) | |-->Device "NVIDIA GeForce"
    (**) |-->Input Device "Mouse1"
    (**) |-->Input Device "Keyboard1"
    (**) Option "AutoRepeat" "500 30"
    (**) Option "XkbRules" "xfree86"
    (**) XKB: rules: "xfree86"
    (**) Option "XkbModel" "pc105"
    (**) XKB: model: "pc105"
    (**) Option "XkbLayout" "us"
    (**) XKB: layout: "us"
    (==) Keyboard: CustomKeycode disabled
    (WW) `fonts.dir' not found (or not valid) in "/usr/X11R6/lib/X11/fonts/local/".
    Entry deleted from font path.
    (Run 'mkfontdir' on "/usr/X11R6/lib/X11/fonts/local/").
    (**) FontPath set to "/usr/X11R6/lib/X11/fonts/misc/,/usr/X11R6/lib/X11/fonts/75dpi/:unscaled,/usr/X11R6/lib/X11/fonts/100dpi/:unscaled,/usr/X11R6/lib/X11/fonts/Type1/,/usr/X11R6/lib/X11/fonts/Speedo/,/usr/X11R6/lib/X11/fonts/75dpi/,/usr/X11R6/lib/X11/fonts/100dpi/"
    (**) RgbPath set to "/usr/X11R6/lib/X11/rgb"
    (==) ModulePath set to "/usr/X11R6/lib/modules"
    (WW) checkDevMem: failed to open /dev/mem (Operation not permitted)
    linear framebuffer access unavailable
    (--) Using syscons driver with X support (version 2.0)
    (--) using VT number 9


    Fatal server error:
    xf86EnableIO: Failed to open /dev/io for extended I/O


    I am not using linux, but (No flames please, its all X) FreeBSD 5.0, if that helps. Does it have anything to do with the fonts error? I am fixing that right now...

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    It's certainly not related to the fonts. I would rather believe that it is because you're trying to run the X server as a normal user without having SUID root on it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •