Find the answer to your Linux question:
Results 1 to 2 of 2
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    How to get a window to appear maximised?

    I write code using xemacs (proper old skool, I know, and I like it!)

    Anyway, I have a little bash script to set it up how I want it, which is as follows:

    xemacs -bg ivory $1 &
    This sets up xemacs just fine ... but the window pops up smaller than the actual screen and I have to then maximise the window every time I run my script. I presume that setting of the window size is an X11 option rather than an xemacs option - so how can I get xemacs to appear maximised when I run my script? What option do I use?

    I'm running Gnome on Debian 5.0 (Lenny).

    Thanks in advance.

  2. #2
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Boston, MA
    Xemacs has a geometry option you can set.

    man xemacs

    -geometry ##x##+##+##
    Specify the geometry of the initial window. The ##'s represent a number; the four numbers are width (characters), height (characters), X offset (pixels), and Y offset (pixels), respectively. Partial specifications of the form ##x## or +##+## are also allowed. (The geometry specification is in the standard X format; see X(1) for more information.)
    And regular emacs has start fullscreen or start maximized options.

    Otherwise, various window managers have differing capabilities in this area. AFIAK, nautilus sucks in this regard. You could run your GNOME session with openbox as the wm, which easily can do this by setting in your rc.xml file something like

    <application name="xemacs">

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts