Find the answer to your Linux question:
Results 1 to 2 of 2
I tried a GUI software to configure my bamboo tablet, and it apparently messed with my configuration in a way I'm not being able to fix. I thought it would ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Apr 2007
    Posts
    214

    [SOLVED] How to have udev/hal ignoring a specific device, so it obbeys


    I tried a GUI software to configure my bamboo tablet, and it apparently messed with my configuration in a way I'm not being able to fix.

    I thought it would only remove or replace xorg lines, but apparently there is something more, because I've restored xorg.conf and it still does not work. Perhaps I've once done something so that udev and/or hal would ignore the tablet, so it would obey xorg.conf's rules... but if that's really the case, I don't remember what it was anymore...

    The main problem is that the "keepshape" option apparently exists only via xorg.conf.


    If that gives anyone any clues, the device name is not set by xorg.conf anymore, that is, "xsetwacom sytlus [...]" will return "cannot find device stylus" (which is its identifier on xorg.conf) , but I can find its current name through "xsetwacom list dev" command: "Wacom Bamboo".

    I can also see the same name through "cat /proc/bus/input/devices", followed by:

    S: Sysfs=/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1:1.0/input/input3

    Whereas it would usually be "Option "Device" "/dev/input/wacom"" on xorg.conf...


    Any help would be much appreciated. Thanks.
    Last edited by the dsc; 03-01-2011 at 03:39 PM.
    Openbox + tint2 desktop. Debian testing, liquorix kernel

  2. #2
    Linux Newbie
    Join Date
    Apr 2007
    Posts
    214
    Nevermind, got it fixed, thanks to my own "blog":

    https://www.linuxquestions.org/quest...orget-it-3084/
    Openbox + tint2 desktop. Debian testing, liquorix kernel

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •