Find the answer to your Linux question:
Results 1 to 2 of 2
I'm having this problem for some time, does it happen to anyone else? I have fantasdic set to "pop up" with control-alt-d on openbox*, but it has not been working ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Apr 2007
    Posts
    214

    "The program 'fantasdic' received an X Window System error"


    I'm having this problem for some time, does it happen to anyone else?

    I have fantasdic set to "pop up" with control-alt-d on openbox*, but it has not been working for a while, I don't even remember anymore when it did work, if it really ever did. I guess it did, but it may have been back then when I was using KDE 3, several years ago.

    It works only for the first time it's called, but then it stays on the "system tray" (as it should), and it does not respond to a second command. The error message (trying to run either the "script" or the command from the console, or as it appears on xsession-errors, when trying the openbox hotkey) is:

    The program 'fantasdic' received an X Window System error.
    This probably reflects a bug in the program.
    The error was 'BadValue (integer parameter out of range for operation)'.
    (Details: serial 251 error_code 2 request_code 18 minor_code 0)
    (Note to programmers: normally, X errors are reported asynchronously;
    that is, you will receive the error a while after causing it.
    To debug your program, run it with the --sync command line
    option to change this behavior. You can then get a meaningful
    I tried running with the --sync as suggested, but it just gives the syntax help (which does not even present such option).


    Should I report a bug or is there something else I should try first? I tried running it on various desktop environments, mostly openbox and fluxbox, but also KDE and Gnome.



    ____________________________

    * with the aid of a script that actually runs the fantasdic command, apparently openbox can't do it for some reason -- perhaps I have to "protect" the ` character on the xml file? The command is "fantasdic All `xclip -o`", where "All" is the name of the group of dictionaries, and xclip -o prints the content of the clipboard.
    Openbox + tint2 desktop. Debian testing, liquorix kernel

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,453
    Have you tried rebuilding the application on your new(er) system (assuming you can access the source code)?
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •