Find the answer to your Linux question:
Results 1 to 6 of 6
Lately my optical mouse has been misbehaving. Clicks seem to be auto-repeated so that one click behaves like two or three. At first I thought it was just a dirty ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Engineer hazel's Avatar
    Join Date
    May 2004
    Location
    Harrow, UK
    Posts
    1,281

    Hyperactive mouse


    Lately my optical mouse has been misbehaving. Clicks seem to be auto-repeated so that one click behaves like two or three. At first I thought it was just a dirty mouse, so I cleaned it carefully as described in a HOWTO that I googled. That didn't solve the problem.

    Then I noticed that this doesn't seem to occur in Debian, only in Crux. This now makes me think it's X that is causing the problem, not my mouse. On Debian Wheezy I have xorg-server 1.7.7 but it's 1.10.0 on Crux 2.7. Has anyone else had this problem with a recent xorg?

    In desktop environments like gnome you can configure the mouse ad lib but I am using a simple window manager ( openbox). The xset utility lets you change the acceleration of your mouse but not the click parameters. So how do I get my mouse to calm down?
    "I'm just a little old lady; don't try to dazzle me with jargon!"
    www.hrussman.entadsl.com

  2. #2
    Just Joined!
    Join Date
    Mar 2011
    Location
    Stanmore, an Inner Western Suburbs town near Sydney
    Posts
    14
    Quote Originally Posted by hazel View Post
    Lately my optical mouse has been misbehaving. Clicks seem to be auto-repeated so that one click behaves like two or three. At first I thought it was just a dirty mouse, so I cleaned it carefully as described in a HOWTO that I googled. That didn't solve the problem.

    Then I noticed that this doesn't seem to occur in Debian, only in Crux. This now makes me think it's X that is causing the problem, not my mouse. On Debian Wheezy I have xorg-server 1.7.7 but it's 1.10.0 on Crux 2.7. Has anyone else had this problem with a recent xorg?

    In desktop environments like gnome you can configure the mouse ad lib but I am using a simple window manager ( openbox). The xset utility lets you change the acceleration of your mouse but not the click parameters. So how do I get my mouse to calm down?
    First thing to try is another mouse, borrow one, buy a cheap one or a spare and see if it behaves the same
    Good luck.

  3. #3
    Just Joined!
    Join Date
    Mar 2007
    Posts
    1

    Exclamation Hyeractive Mouse

    I have the same problem of hyperactive optical mouse.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Mar 2011
    Location
    Stanmore, an Inner Western Suburbs town near Sydney
    Posts
    14
    Quote Originally Posted by A. K. Kapoor View Post
    I have the same problem of hyperactive optical mouse.
    What do your your

    /etc/X11/xorg.conf... entries look like.


    Post them here.

  6. #5
    Linux Newbie
    Join Date
    Sep 2007
    Posts
    218

  7. #6
    Linux Engineer hazel's Avatar
    Join Date
    May 2004
    Location
    Harrow, UK
    Posts
    1,281
    Quote Originally Posted by Dookus View Post
    What do your your /etc/X11/xorg.conf... entries look like?
    Well, the mouse section of mine looks like this:
    Section "InputDevice"
    Identifier "Mouse0"
    Driver "mouse"
    Option "Protocol" "ExplorerPS/2"
    Option "Device" "/dev/input/mice"
    Option "ZAxisMapping" "4 5"
    Option "Emulate3Buttons" "true"
    EndSection

    As you can see, I'm still using the old xf86 drivers. Perhaps I should switch to evdev.
    "I'm just a little old lady; don't try to dazzle me with jargon!"
    www.hrussman.entadsl.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •