Find the answer to your Linux question:
Results 1 to 4 of 4
I'm having trouble setting the background in fluxbox. I don't even have any clue how to do it!!! The picture that I want to set as my background is: /home/alex/Misc./Pics/neu2.jpg ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Nov 2004
    Posts
    166

    Fluxbox Background


    I'm having trouble setting the background in fluxbox. I don't even have any clue how to do it!!! The picture that I want to set as my background is:

    /home/alex/Misc./Pics/neu2.jpg

    does anyone know how to do this???
    Registered Linux User Number 373366

  2. #2
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Farnborough, UK
    Posts
    1,305
    Lansbury's Lido

    thekiadriver on #linuxforums - fleetingly

  3. #3
    Linux Newbie
    Join Date
    Nov 2004
    Posts
    166
    ok it still doesn't work this is what I do:

    I become root using 'su'
    I then cd to ~/.fluxbox
    I type 'vim init'
    There is already a line that says: 'session.screen0.rootCommand:'
    I add 'fbsetbg -f ~/Misc./Pics/neu2.jpg'
    I save it using 'ZZ'.
    Then I reapply the style, which is just an edited version of minimal. (if you need, i can post what the style looks like.)

    The background is still the same!!! If i got back into the file. It still just says 'session.screen0.rootCommand:' It erased my line of code. What's wrong here?
    Registered Linux User Number 373366

  4. #4
    Linux Newbie
    Join Date
    Nov 2004
    Posts
    166
    I think that the problem might be in my editng of the "minimal" style. Here is what my style looks like:

    Code:
    ! Minimal (c) 2000 Jeff Raven
    ! Blackbox window manager resource defaults, with an
    ! eye towards consuming as little of an 8-bit palette
    ! as possible. As an additional bonus, with the changes
    ! as of Blackbox 0.60.3, it should also use very little
    ! memory.
    
    toolbar:                        Flat Solid
    toolbar.color:                  Black
    
    toolbar.clock:                  ParentRelative
    toolbar.label:                  ParentRelative
    toolbar.windowLabel:            ParentRelative
    
    toolbar.button:                 ParentRelative
    toolbar.button.pressed:         Flat Solid
    toolbar.button.pressed.color:   LightGreen
    toolbar.button*picColor:        Green
    
    toolbar.textColor:              Green
    toolbar.justify:                center
    
    window.title.focus:             Flat Solid
    window.title.focus.color:       Black
    window.title.unfocus:           Flat Solid
    window.title.unfocus.color:     Black
    
    window.label.focus:             ParentRelative
    window.label.focus.textColor:   Green
    window.label.unfocus:           ParentRelative
    window.label.unfocus.textColor: Green
    
    window.button.focus:            ParentRelative
    window.button.focus.picColor:   Green
    window.button.unfocus:          ParentRelative
    window.button.unfocus.picColor: Green
    window.button.pressed:          ParentRelative
    
    window.handle.focus:            Flat Solid
    window.handle.focus.color:      Black
    window.handle.unfocus:          Flat Solid
    window.handle.unfocus.color:    Black
    
    window.grip.focus:              Flat Solid
    window.grip.unfocus:            Flat Solid
    window.grip*color:              Green
    
    window.frame.focusColor:        Black
    window.frame.unfocusColor:      Black
    
    window.justify:                 center
    
    menu.title:                     Flat Solid
    menu.frame:                     Flat Solid
    menu.hilite:                    Flat Solid
    
    menu.title.color:               Black
    menu.title.textColor:           Green
    menu.title.justify:             center
    
    menu.frame.color:               Black
    menu.frame.textColor:           Green
    menu.frame.justify:             left
    
    menu.hilite.color:              LightBlack
    menu.hilite.textColor:          Black
    
    menu.bullet:                    Triangle
    menu.bullet.position:           Right
    
    borderColor:                    Green
    
    bevelWidth:                     1
    borderWidth:                    1
    handleWidth:                    4
    
    *Font:                          -*-helvetica-*-r-*-*-12-*-*-*-*-*-*-*
    
    rootCommand:                    fbsetbg /home/alex/Misc./Pics/neu2.jpg
    I have also noticed that there are 2 init files. I have done what i said in my previous post to both of them, the same thing happened!
    Registered Linux User Number 373366

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •