Find the answer to your Linux question:
Results 1 to 5 of 5
I have a funny problem. I am running Openbox with lxpanel with Debian Stable. I originally installed Debian with XFCE, and afterwards installed a few Gnome themes. With XFCE I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! Randicus's Avatar
    Join Date
    Sep 2011
    Location
    China
    Posts
    74

    Question Changing icon themes in Openbox.


    I have a funny problem. I am running Openbox with lxpanel with Debian Stable. I originally installed Debian with XFCE, and afterwards installed a few Gnome themes. With XFCE I was using NuoveXT2.2 icons.

    The problem: I want to use Nuove icons with Openbox. I have played around with it quite a bit and have reached the conclusion that Debian's "Appearance" and XFCE's "Appearance Settings" have no effect. The key seems to be QtConfig. If I save the settings in QtConfig, the icons will change to Nuove after I open the web browser, believe it or not. But the next time I log in the icons have reverted to Gnome.

    I have tried adding QtConfig to the Openbox startup.sh and tried editing the .gtkrc-2.0 and .gtkrc-2.0mine files created by lxappearance. The best I can accomplish is; after logging in the icons are Nuove until Cairo-Clock and GKrellM load, then they change to Gnome.

    Any thoughts on how to convince Openbox to retain the desired icon theme after completing the start-up sequence?

  2. #2
    Just Joined! Randicus's Avatar
    Join Date
    Sep 2011
    Location
    China
    Posts
    74
    First; I apologise for a new post instead of editing the first one, but it appears that there is a limited time allowed to edit posts.

    I have discovered from a discussion at LinuxQuestions that I was correct about QtConf being the key, but not the way I thought. Apparently, Qt does not work with Openbox. So I removed it and installed Compiz. Half the problem is solved. My Cairo-Clock is no longer surrounded by a black box. It now has wonderful transparency!
    However, I still cannot get the icons to remain permanently. They still change to Gnome after Openbox finishes loading, and still occasionally switch to the desired nuove theme when I open the internet browser.mad:

  3. #3
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Posts
    3,842
    I don't know if this effects you Randicus.

    antiX-forum - View topic - "Change GTK2 and Icon Themes" not working

    Looks like updating LXappearance breaks some stuff. Just posting for info.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  4. #4
    Just Joined! Randicus's Avatar
    Join Date
    Sep 2011
    Location
    China
    Posts
    74
    Thanks, but it is not an up-date issue.
    However, I believe I am getting closer. Of the two dialogue boxes, the one called Appearance Settings is for lxappearance. For some reason, settings are not being saved. If the dialogue box is closed and re-opened, the settings have reverted to clearlooks with Gnome icons.
    The icon theme occasionally changing to the desired one when the web browser is opened is what is baffling me.

  5. #5
    Just Joined! Randicus's Avatar
    Join Date
    Sep 2011
    Location
    China
    Posts
    74
    The problem is almost completely fixed. (About 19/20 th)

    One problem was lxappearance settings not being saved.
    I switched to fbpanel.
    I removed XFCE appearance settings and all the other XFCE packages Synaptic wanted to remove along with it, but kept lxappearance, because both gtk theme switcher and gtk theme manager do not have options to change icons.
    I then removed lxappearance and switched the icon theme to Gnome-Dust.

    The result is the proper theme and fount are system-wide, but the proper icons are only on fbpanel. Of course, I still have the situation where the icons often switch to the proper theme when the web browser is opened, and at least once they kicked in while using the file manager.

    To compensate for the lack of icon choosing with gtk tools, I followed a guide on the Arch site and added these two lines to lines to my .gtkrc.mine:
    Code:
    include "/home/randicus/.gtkrc-2.0"
    include "/usr/share/themes/gnome-dust/gtk-2.0/gtkrc"
    But it has not resolved the problem.

    This is my Openbox startup.sh
    Code:
    xcompmgr &
    # My wallpaper 
    eval `cat $HOME/.fehbg` &  
    fbpanel &
    cairo-clock &
    gkrellm &
    The only thing left to do is get the icon theme to load when booting.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •