Find the answer to your Linux question:
Results 1 to 5 of 5
I turned on a global hotkey for 2 programs, Audacious and VLC. The global hotkey is Pause bound to "Play/Pause." If I start Audacious and VLC (in this order), then ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2010
    Posts
    12

    Question gobal hotkeys are lost with 2 programs


    I turned on a global hotkey for 2 programs, Audacious and VLC. The global hotkey is Pause bound to "Play/Pause." If I start Audacious and VLC (in this order), then only Audacious reacts to the global hotkey. This is okay. If I terminate Audacious, VLC does not react to the global hotkey until restarted.

    • Can I change this behavior? The ideal solution would be to reroute global hotkeys without restarting GUI processes.
    • What program exactly is responsible for this behavior? The Xorg server?

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,419
    Sorry for the delay in replying to this. What happens if you click on the VLC window, and then press the defined "Pause" key? Does that instance get the message?
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Just Joined!
    Join Date
    Mar 2010
    Posts
    12
    Nothing happens.

  4. #4
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,419
    Well, I tried changing my keyboard shortcut preference for media Pause, and nothing happens on my system (RHEL 6 clone, Scientific Linux)... Sorry, but I don't know what else to tell you.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  5. #5
    Just Joined!
    Join Date
    Mar 2010
    Posts
    12
    I bind keys with the file
    $HOME/.Xmodmap
    keycode 127 = XF86AudioPlay
    If "xmodmap" does not read it by default, "xmodmap $HOME/.Xmodmap". Also global hotkeys may be disabled in preferences of Audacious and other programs that receive keys.

    I do this because I don't have a multimedia keyboard. I guess that it does not matter which key is bound to "Play/Pause".

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •