Find the answer to your Linux question:
Results 1 to 2 of 2
Hi there, I am running Debian Wheezy and I use KDE as my desktop environment at work. Most of the people here use Windows/Outlook for e-mail and thus most e-mails ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2007
    Location
    Toronto, Canada
    Posts
    8

    Making IceDove (Thunderbird) show network folders in a KDE environment


    Hi there,
    I am running Debian Wheezy and I use KDE as my desktop environment at work. Most of the people here use Windows/Outlook for e-mail and thus most e-mails are formatted in HTML. I use IceDove because its HTML support is much better than Kmail.

    Now, I have several Network Folders (smb) set up in Dolphin. When I used to use Kmail, these folders would show up in the Save/Attach options and I would directly use files on the network share.

    Once I switched to IceDove, I was not able to do this. The problem appears to be that the Attach/Save dialogue comes from GTK (sorry but I don't know how else to put it). I'm attaching screenshots for clarification.

    My question: is it possible for me to configure IceDove/GTK to show network folders or to configure network folders in them or is the only option to go and install something like Nautilus (which installs a bunch of Gnome stuff)?

    Any help is much appreciated.

    Thanks,
    Vivek

    IceDove-attach.jpg

    kmail-attach.jpg

  2. #2
    Just Joined!
    Join Date
    Oct 2007
    Location
    Toronto, Canada
    Posts
    8
    Ok. Turns out that there are a few ways this can be done.

    Option 1: Use gvfs
    gvfs-mount is what Nautilus uses when it mounts network shares like Samba shares. The files are mounted at ~/.gvfs/. If you mount the share with gvfs, it shows up in the IceDove Save/Attach dialog. Not sure if a gvfs mount is done at boot time. It didn't do that for me.

    Option 2: Mount Network Share at mount point with full user priveleges
    If I mount the share with option uid and gid at a mount point where the user has full priveleges, it turns up in the IceDove dialog. No need for gvfs and such things. When I say full user priveleges, I mean that the user using IceDove must have privileges to access the mount point.

    I opted for option 2 and edited fstab to mount the share at boot.

    Vivek

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •