Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
I have been to ati, and d/l there rpm, for the Xfree86 4.2.xxx, I also download the XFree86 4.2.xxx.rpm as well. I can run both the rpms. I have already ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2003
    Posts
    8

    ATI Radeon 9000 pro drivers


    I have been to ati, and d/l there rpm, for the Xfree86 4.2.xxx, I also download the XFree86 4.2.xxx.rpm as well. I can run both the rpms. I have already updated to the 4.2 Xfree Server, but when the ati rpm tries to create a module for my video card it cant seem to do it. It checks a particular spot on my linux system, I always thought that your linux kernal was located in the usr/src/linux-XXX, and I have recompiled my kernel there. But the rpm checks in another place where the ending of the kernel name is mdk. It starts saying that it has errors in compiling those files, and it cant make my module. I know there is a way to create your own module with this rpm, but I dont know how to or where to find out. I cant get X windows to run until I can get it to create that module. What can I do? or where can I get info from someone who has had this problem b4?

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    What errors are you getting? If you don't already have that, you might have to create a symlink named /usr/src/linux (only) that points to the actual directory where the kernel source is installed.

  3. #3
    Linux Engineer
    Join Date
    Dec 2002
    Location
    New Zealand
    Posts
    766
    it wants a kernel ending in mdk?? that qwould mean u have downloaded a mandrake driver. (I guess ur using redhat). go back to ati and find either a redhat rpm or a src file.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jun 2003
    Posts
    8

    where is the kernel installed literally?

    Yes I d/l the rpm, but I dont know if you could call it a mandrake driver, the version of linux I am currently running is mandrake. So I am assuming that maybe the usr/src/linux-2.4blah blah, is just the src code, and the kernel-2.4.*.mdk, is where the kernel itself resides. At least that is what I am thinking from the two comments. it is just when I run the rpm to create the driver module it is pulling up a ton of erros and not creating the driver module. Could it be becasue I have not compiled the kernel correctly? I know when you change the kernel config you do a make dep. Are there other commands you need to do. I vaualy remeber compile a kernel a long time ago, and I thought there was one part where you would compile lilo in, and your modules, and other commands besides the make dep command. That could be why the RPM doesnt work. I just might not know how to compile the kernel. What are the commands to compile the kernel?!?!?!

  6. #5
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    No, module compilations only use the kernel header files. Can you post what errors you're getting?

  7. #6
    Just Joined!
    Join Date
    Jun 2003
    Posts
    8

    back stepped a little

    ok guys I took a couple steps back in the process I am running mandrake 7.1. I reinstalled completly. Learned how to use a couple console programs like "lynx"(which rocks). Now Ati didnt create these rpms. They were create by another group of ppl working through them. They have 2 different RPM's. One is for Xfree 4.1 and another for 4.2. I updated my Xfree server to 4.2. Then I tried to run the rpm and it gives me this error.(file /usr/X11R6/lib/libGL.so.1.2 from install of fglrx-glc22-4.2.0-2.5.1 conflicts with file from package XFree86-libs-4.1.0-17mdk)
    It looks like even when I updated my Xfree server to 4.2 the mandrake part of it wasnt updated. The last time I tried to just do a force off the rpm and installed, but I dont want to do that unless I know that I shouldnt worry about this error. because I think a lot of these problems are just becasue I am not effectivly getting rid of the mandrake part of the system. Any tips on how to solve this w/o a force. If I have to force it I will and tell you the errors I am getting when I run the rpm, as it tries to create the module.

  8. #7
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Maybe you just didn't upgrade your XFree86-libs package, but only the XFree86 core package?

  9. #8
    Just Joined!
    Join Date
    Jun 2003
    Posts
    8

    hmmmmm

    I tried to update my lib files ealier today, it was giving me a cant find modules configurator error. So I did a little more research and found out that when I compile my kernel, if it is the same kernal that is already compiled. It wont update my modules, I have to delete the folder and recreate the modules from the new compile. When I force the RPM, it tell s me that I do need to reconfigure my kernel, so that it will do MTDD or something. So I tried to comile a new kernel with the latest kernel out there. I was able to compile the kernel, but my lilo.conf didnt exist in my boot folder. Then I read a option that you can use with the kernel compiling called make install. Where it tries to set up a lilo configuration. However I dont know if it created the lilo.conf, cause it wont boot now. I have the options to choose what to boot from lilo. Including my new compiled kernel. I just need to figure out how to get the kernel to boot. It gives me a error about not being about not being able to mount the ufs or somethin. I know that if I can get into the newly compiled kernel that my libc files will be updated enough to install the rpm, and with my modules finally configured properly it should be able to create the ato driver. At least that is what I hope. Off to do some research agian....

  10. #9
    Just Joined!
    Join Date
    Jun 2003
    Posts
    8

    closer

    k, I decedid to go on and force the package after a recompiled my kernel. I found this one setting that was just loopy. If you had it turned on it would not updates your modules/linux***.mdk. Even if you did a make modules, then a make modules_install. It would ignore those I guess b/c of that one setting in the kernel. Once I changed that and recompiled. The rpm created the driver the first time around with a couple of errors though. I will post those when I get up tomoz and xperiment with them. Something about I cant start this driver w/o initializing dri first. I appreciate all the help so far.

  11. #10
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    MTDD should probably be MTRR (stands for Memory Type Range Register). DRI stands for Direct Rendering Interface. You will need to select both of them explicitly in your kernel configuration. You will find the MTRR option under Processor type and features, and DRI under Character devices. Be sure to compile AGPGART support as well.

    Could you post the exact boot error that the new kernel gave you?

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •