Find the answer to your Linux question:
Results 1 to 2 of 2
Well, another newbie to Linux... I've been using Mandrake 10.0. (with KDE) for a week now. I even managed to install a new graphic card. Everything has worked fine for ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2004
    Posts
    1

    XFree fails to start


    Well, another newbie to Linux...
    I've been using Mandrake 10.0. (with KDE) for a week now. I even managed to install a new graphic card. Everything has worked fine for a few days, but now, without any obvious reason, Xfree fails to start (the screen blinks three times and then goes to text mode).

    I found this in my /var/log/messages:
    Code:
    localhost mdkkdm[1783]: IO Error in XOpenDisplay
    localhost mdkkdm[1590]: X server for display :0 terminated unexpectedly
    localhost mdkkdm[1590]: Display :0 cannot be opened
    When I do modprobe nvidia and startx, it works.
    Trying startx only gives me something like "screen(s) found, but none have usable configuration". But I didn't change any configuration. Can someone please tell me what went wrong?

  2. #2
    Linux Enthusiast
    Join Date
    Jun 2004
    Location
    Windsor, CO
    Posts
    656
    Maybe you should set the nvidia module to load on bootup. I don't use Mandrake (it annoys me), and I'm not sure how it handles start-up files, but you should be able to set/force a module to load on boot-up.
    Emotions are the key to the soul.
    Registered Linux User #375050

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •