Find the answer to your Linux question:
Results 1 to 4 of 4
First off here is the hardware specs of my machine: CPU: AMD Phenom II X6 1035T MOBO: GA-880GM-USB3 (Socket M2) GPU: 1024MB GeForce GTS 450 (MSI) DVD: Optiarc DVD RW ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2012
    Posts
    15

    Angry Window Managment Barely Usable, not sure if X or GNOME


    First off here is the hardware specs of my machine:

    CPU: AMD Phenom II X6 1035T
    MOBO: GA-880GM-USB3 (Socket M2)
    GPU: 1024MB GeForce GTS 450 (MSI)
    DVD: Optiarc DVD RW AD-7280S SATA
    HDD: 932GB Seagate ST1000DM 003-1CH162 SATA
    RAM: 16.0 GB Dual-Channel DDR3 686MHz
    MOUSE: Rat7

    This problem I am about to describe has occurred consistently on the following distros:

    Ubuntu 12 - tried GNOME
    Fedora 17&18 - tried GNOME & Cinnamon
    Linux Mint 15 - tried Cinnamon

    Also occurs on the live cd's of all of the above Distros


    Problem:
    Generally after logging in, my desktop will be usable for a few minutes with no problems, providing I don't open Firefox. After I open firefox or at some other random point (at this point firefox is the only thing that consistently causes this problem)things start going funky. Please note that these problems also occur on a Live CD. Here is a list of the symptoms:

    - Mouse only works in the active window.
    - Can not switch active window using the mouse, only keyboard (Alt + Tab or have 1 window per workspace and switch workspaces with Ctl + Alt + arrow)
    - can not re-size active window
    - can not get a right click menu on the desktop
    - can not use any GNOME/Cinnamon desktop menus
    - must restart the computer to get this problem to resolve

    I would assume there is an issue with either X or GNOME because this has happened on multiple distros. I have not tried KDE and thought that maybe there might be a change if I got away from GNOME entirely.

    This problem makes the desktop entirely unusable unless you quickly open a terminal window in another workspace and then use it once the desktop goes haywire.

    EDIT: Turns out the problem was with my RAT7 Mouse. See last post for details.
    Last edited by KroniK907; 06-19-2013 at 07:03 PM.

  2. #2
    Linux Enthusiast
    Join Date
    Jan 2005
    Location
    Saint Paul, MN
    Posts
    636
    I have been getting random points where the mouse gets stuck in "highlight" for copy mode and I have to resort to the alt-tab to switch between windows. I'm using KDE so it might in the UDEV or some other place. When in this mode, if I "switch to another GUI session (via "Switch User"), the mouse is working fine. I have tried several mice and at some random time it happens. It may be many days apart or within an hour. It appears to be very random.

  3. #3
    Just Joined!
    Join Date
    Nov 2012
    Posts
    15
    I have found that for the most part I can navigate everything by using the keyboard. Ctl + Q has been a life saver because I cant access the window control buttons with my mouse most of the time. Im about to enter a bug into redhats bugzilla for specifically fedora but I know there is something else going on here.

    UPDATE: Tried installing proprietary Graphics driver and nothing happened... Still the same bug.

  4. #4
    Just Joined!
    Join Date
    Nov 2012
    Posts
    15

    Wink Window Managment Barely Usable, not sure if X or GNOME [FIXED]

    I have found a solution!

    The problem lies in the fact that I have a RAT 7 Mouse. This mouse specifically has a Mode switch button which I guess sends a button press to xorg but never a button up to release the button. so xorg gets all confused and freaks out.

    anyway, the short term solution to fix your current xorg session is to do an Alt+f2 and give the command
    Code:
    telinit3
    which will drop you to a terminal and kill X. Then restart x by loging in and running:
    Code:
    startx
    Then you should have full window control etc.

    Now for the permanent fix. open a terminal and do the following:
    Code:
    sudo touch /etc/X11/xorg.conf
    Then you must add a section which will disable the buttons on your RAT 7 mouse that cause the bug. so open the xorg.conf with vi or your preferred editor and add the following lines.

    Code:
    Section "InputClass"
            Identifier "Mouse Remap"
            MatchProduct "Saitek Cyborg R.A.T.7 Mouse"
            MatchDevicePath "/dev/input/event*"
            Option "ButtonMapping" "1 2 3 4 5 6 7 2 9 10 11 12 0 0 0"
    EndSection
    Restart your machine and it should have no more issues.

    If a mod could please close the topic and mark as FIXED that would be great!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •