Find the answer to your Linux question:
Results 1 to 5 of 5
Like Tree1Likes
  • 1 Post By rokytnji
I'm using vanilla Debian Jessie and after the latest dist-upgrade it started to blank my KDE desktop after one minute of idling no matter what I do. I mean, I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2011
    Posts
    11

    Can't disable screensaver / screen blanking


    I'm using vanilla Debian Jessie and after the latest dist-upgrade it started to blank my KDE desktop after one minute of idling no matter what I do.

    I mean, I have tried to:

    $ xset s off
    $ xset s noblank
    $ xset -dpms

    And I have

    Option "BlankTime" "0"
    Option "StandbyTime" "0"
    Option "SuspendTime" "0"
    Option "OffTime" "0"

    in my serverlayout section in the xorg.conf.

    I also have "NODPMS" in the monitor section of the xorg.conf.

    There is no screensaver active in my KDE configuration.

    But still my screen blanks after one minute of idling.

    Where should I look next? I'm using proprietary nVidia drivers, btw.

  2. #2
    Linux User IsaacKuo's Avatar
    Join Date
    Feb 2005
    Location
    Baton Rouge, LA, USA
    Posts
    406
    I'd be interested in anything you find out. I haven't had luck turning DPMS off ever since Lenny. My kludgy solution ever since then has been to install xscreensaver and set it to the maximum timeout allowed (720 minutes). I also set it to do "Only One Screensaver" with "Wander" as the screensaver since it consumes little CPU.

    (To get "Wander", install xscreensaver-data-extra )

    So, again, my proposed solution is:

    1) install xscreensaver with apt-get install xscreensaver xscreensaver-data-extra
    2) run xscreensaver
    3) set it to Blank After 720 minutes

    It's not a true solution, and it's ridiculously kludgy...but it works. Or at least, it works on all of my systems.
    Isaac Kuo, ICQ 29055726 or Yahoo mechdan

  3. #3
    Linux Enthusiast
    Join Date
    Dec 2011
    Location
    Turtle Island West
    Posts
    520
    I'm not sure if this has anything to do with the issue here, but ever since I got my new(used) LCD monitor for super cheap a couple of months ago, it seems to blank all by itself after idling a minute or two.

    I have no xscreensaver running. I've had the same distro for 8 years and never had this issue before. It has kind of mystified me also. I always thought this was something you had to tell it to do, but I now have no control over it, and the OSD menu has nothing relevant.

    As an un-related sidednote, with this monitor (ViewSonic VA903b), once XWindows fires up, I can no longer get back to a tty. Ctrl-Alt-F1 blanks the screen and the screen shows "No Signal", but it works fine at boot time. Odd.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Jul 2008
    Posts
    4,205
    I don't use KDE.

    I use xscreensaver from synaptic. Then I modify the startup in .fluxbox and .icewm by placing "xscreensaver -nosplash &" below the conky & line. so it will turn on at boot.

    Example:

    conky &
    xscreensaver -nosplash &

    Screen does not blank out. Hopefully you guys will be able to incorporate this suggestion into your KDE startup and post the solution in this thread.

    or use this script

    Code:
    #!/bin/bash
    
    minutes=16
    seconds=$((minutes * 60))
    
    if xset q | grep -q "Standby: [1-9]"; then
        xset  dpms 0 0 0 s 0 0 
        echo "Sleep disabled"
    else
        xset  dpms $seconds $seconds $seconds s $seconds $seconds 
        echo "Sleep enabled.  Delay: $minutes minutes"
    fi
    or for a temp fix while watching a movie

    Code:
    xset -dpms; xset s off
    typed into a terminal while watching a movie will work also.
    Miven likes this.

  6. #5
    Linux Enthusiast
    Join Date
    Dec 2011
    Location
    Turtle Island West
    Posts
    520
    Doh. I've been using linux since about 1997 and I've never used xset, ever.

    Thank you for that 'xset -dpms' tidbit. It appears to have worked.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •