Find the answer to your Linux question:
Results 1 to 4 of 4
So I used a script that was supposed to make it so that me screen didn't fade to black when flash was on, but it did the total opposite. Now ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2013
    Posts
    2

    Huge issue thanks to a script. Help?


    So I used a script that was supposed to make it so that me screen didn't fade to black when flash was on, but it did the total opposite. Now whenever I try to open Mozilla Firefox or play a video in VLC my screen instantly flashes, and I end up at the login screen.

    This is the script I used, I have removed it completely.. The problem still persists after a reboot.

    #!/bin/bash

    # Cleanup any bad state we left behind if the user exited while flash was
    # running
    gconftool-2 -s /apps/gnome-screensaver/idle_activation_enabled --type bool true

    we_turned_it_off=0

    while true; do
    sleep 60
    flash_on=0

    for pid in `pgrep firefox` ; do
    if grep libflashplayer /proc/$pid/maps > /dev/null ; then
    flash_on=1
    fi

    ss_on=`gconftool-2 -g /apps/gnome-screensaver/idle_activation_enabled`

    if [ "$flash_on" = "1" ] && [ "$ss_on" = "true" ]; then
    gconftool-2 -s /apps/gnome-screensaver/idle_activation_enabled \
    --type bool false
    we_turned_it_off=1
    elif [ "$flash_on" = "0" ] && [ "$ss_on" = "false" ] \
    && [ "$we_turned_it_off" = "1" ]; then
    gconftool-2 -s /apps/gnome-screensaver/idle_activation_enabled \
    --type bool true
    we_turned_it_off=0
    fi

    done
    done

  2. #2
    Just Joined!
    Join Date
    Feb 2014
    Posts
    45
    hrm, you may have to remove flash and reinstall it.
    You could have just used a control center and disabled the screensaver, would have caused far less trouble.

  3. #3
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,598
    So, where did you get this script? Just as you don't want to install stuff you don't know about on Windows, this is also true with Linux...
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  4. #4
    Linux Newbie nihili's Avatar
    Join Date
    Dec 2013
    Posts
    193
    Quote Originally Posted by MadmanRB View Post
    hrm, you may have to remove flash and reinstall it.
    i'd rather say you may have to remove gnome-screensaver and reinstall it. or gconf.

    but if the screensaver still kicks in everytime you start firefox, it seems to me the script is still running doing the wrong thing?

    btw, the backslashes "\" mean that a long line continues on the next line; depending on how you copy-pasted the script it might not work because of this and possible other formatting errors.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •